This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

Change BSL for MSP430F4783 with BSL Rocket

Other Parts Discussed in Thread: MSP430F4783


I have bought my "Rocket" and connected it up. Also downloaded the scripter and read the SLAU655. But my device is MSP430F4783 and this is not covered by one of the supported families (section 2.1 of SLAU655). I have tried the available options, but the software in my MSP430 does not change.

So what can I do?



  • Hello Rolf,

    I split your reply off of the previous thread for this needs to be its own separate post. You are correct that the BSL scripter does not support F2xxx/4xxx devices. In this case BSLDEMO2 needs to be used. I have provided the link for it below. I am also including a link to an E2E post with a similar subject. It seems some of these links have been deprecated and will need to be placed on our BSL page. Sorry for the confusion.


    E2E Post:

  • Hi JH

    This was much better - but we are not there yet.
    I can retrieve the BSL version, family and process and apparently the mass erase works (the old code is gone from my target).
    But I keep getting a Communication error.
    I use short wires and signals look Ok on my oscilloscope.
    I have tried all baudrate options.

    Any ideas?


    This is the output:

    >BSLDEMO2 -cCOM12 -m1 -epvrw code.txt
    MSP430 Bootstrap Loader Communication Program (Version 2.01.Rocket)
    Number of mass erase cycles set to 1.
    Transmit standard password...
    BSL version: 1.61 - Family member: F449 - Process: 40B0
    Erase Segment: 0x0
    ERROR: Communication Error!
  • Hi JH

    Sorry, the "-" should be "+"! Then it works!