This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

MSP432E401Y: Can't get MSP to program over serial.

Part Number: MSP432E401Y
Other Parts Discussed in Thread: MSPBSL, MSP-EXP432E401Y

I have been trying to follow the steps outlined  I follow all steps have my BSL rocket firmware correctly setup. When I run my BSL-Scripter it runs through and says 

BSL Scripter 3.3.0
PC software for BSL programming
2019-Feb-26 14:52:15
Input file script is : C:/Users/Al/Desktop/BSl/MSPBSL_Scripter_win_Ethernet/script_uart_app1.txt
[ERROR_MESSAGE]No response bytes received from BSL!

The MSP-EXP432E401Y launchpad is empty. 

are there special steps that I need to take to load the uart BSL on to the processor? I have checked continuity to the process with the UART TX and RX. 

  • Hello Al,

    Did you follow instructions under "Task 4: Preparing the LaunchPad"of "Running the Serial Boot Loader and Downloading an Application Image over Serial Interfaces (I2C, SSI and UART)" to populate resistors R5 and R6 for UART communication. You also need to make sure that R7 - R12 are not populated.

    Also are you programming the Flash bootloader image and then the Application image or directly programming the Application image? Can you provide details of which example project's image you are programming?

  • Yes I have prepared the board as described. I placed a solder bride over the UART R5 and R6. I also checked continuity to the MSP from the TX and RX pins and it is connected.

    I applied a scope to the UART TX to the MSP from the Rocket board and can confirm that it is attempting to send data. It just never receives anything back.

    I have tried doing the exact steps provided in Task 5. I get the same results as shown. This would be the Bootloader image first then the application.

    I have tried loading the bootloader through the JTAG then trying to load the application and I get the same response bytes issue.

    The application that I am trying to load is the same as what I used when I successfully did this over Ethernet.
  • Hello Al,

    I think I have all the information required. You seemed to have followed all the steps outlined in the MSP432E4 Bootlaoder SimpleLink Academy lab.

    Please give me time till 3/8/2019 to try this out and get back with my findings.

  • Hello Al,

    I tried this today and I am able to program the Flash Bootloader (boot_serial_uart_flash). I followed the steps described in the SimpleLink Academy lab that you linked in your original post until Step 5 under Task 5.

    I got the error that you are pointing above "[ERROR_MESSAGE]No response bytes received from BSL!" when the Main Flash of MSP432E4 was not erased. Did you erase the Main Flash of the MSP432E4, before you connect Rocket to it? Step 1 of Task 5 documents erasing the Main Flash.

    The erase of the Main Flash is required as that's the only way to invoke the Bootloader in the ROM. Using this ROM Bootloader, we first program the flash bootloader (boot_serial_uart_flash) and then the application.

    Edit: To erase main flash, follow instruction on this forum post.


**Attention** This is a public forum