This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

MSP430FR5994: ERROR: MSP-FET / eZ-FET recovery failed

Part Number: MSP430FR5994
Other Parts Discussed in Thread: MSP-FET

Just plugged in my new, just out of the box MSP430FR5994.  I tried to program it with example TI code using CCS 9.3 and I got a message saying eZ-FET needs updating so I selected Update.  Update failed so I tried Recover.  Recover failed so I looked for similar solved issues but didn't find any that had a solution.  Downloaded MSPFlasher v1.3.20 and its user Guide which had a note on how to do an automated FET update so I ran that (./MSP430Flasher -n NO_TARGET -s) which also failed.  That at least gave a bit of information when it failed so that is below but I am out of ideas on what to try next.  Thanks for any help.

* -----/|-------------------------------------------------------------------- *
* / |__ *
* /_ / MSP Flasher v1.3.20 *
* | / *
* -----|/-------------------------------------------------------------------- *
* Evaluating triggers...done
* Checking for available FET debuggers:
* Corrupted USB FET firmware detected. Starting recovery.

# Exit: 49
# ERROR: MSP-FET / eZ-FET recovery failed
* ----------------------------------------------------------------------------
* Driver : closed (No error)
* ----------------------------------------------------------------------------

**Attention** This is a public forum