This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

How to unbrick a MSP-EXP432P401R

Somehow I manage to brak my MSP432 eval board, I can no longer flash it using CCS or IAR tools.

MSP-EXP432P401R-LaunchPad Firmware Programmer
Programing OutOfBox_MSP432P401R.out into ......
Initializing debug probe...
Configuring Debugger (may take a few minutes on first launch)...:
Initializing Register Database...
Initializing: CS_DAP_0
Executing Startup Scripts: CS_DAP_0
Initializing: CORTEX_M4_0
Executing Startup Scripts: CORTEX_M4_0
Connecting...
Fatal: CORTEX_M4_0: Error connecting to the target: (Error -1063 @ 0x0)
Device ID is not recognized or is not supported by driver. Confirm device and de
bug probe configuration is correct, or update device driver. (Emulation package
5.1.641.0)
Failed: Failed to evaluate GEL_Connect(): Connect failed

Is there anyway to recover the board?

  • Hi Andre,

    maybe have a look here:

    Or here:

    Or here:

    Dennis


  • In reply to Dennis Eichmann:

    I was able to fix my problem, I guess we can add a 4th cause to the error @1063. In my case somehow my last download managed to lock and disable JTAG preventing any new download from happening.
    I tried to switch to CMSIS-DAP on IAR and flash and it gave me that info and suggested to do a factory reset to solve the problem. That did it.

    Thanks for the quick reply :)
  • In reply to Andre Silveira:

    hy guys i tried to do the factory reset as mentioned, but when I wanted to load the file the ccs said:

    CORTEX_M4_0: GEL: Error loading file 'C:\Users\Christoph\Downloads\2388.msp432_factory_reset.gel': function 'OnTargetConnect()' already defined

    and the status of the gel data was switched to Failed.

    Do you know how I could fix this ?

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.