This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

SK-AM64: Launchpad not recognized in device manager

Part Number: SK-AM64

Hello,

I recently received the sk-am64x for some dev work and am trying to follow the instructions in the quick start guide for the software setup: https://dev.ti.com/tirex/explore/node?node=ABAdBPmmXTJLfIV43c2tDA__FUz-xrs__LATEST 

I was able to successfully flash the SD card, but when I go to connect the board to my PC and look for it in device manager (I am running Windows 10), the device does not come up. I tried following the instructions for the driver installation on the quick start guide as well, but that did not work or change anything that I could see.

How should I go about connecting the starter kit to my PC and have it display in Device manager so that I can communicate with it over COM ports?

Thank you!

  • Hello Ryan,

    Apologies for the delayed response. I have reassigned your thread to the document owner to comment. Please ping the thread if you have not received a response in a day or so.

    Regards,

    Nick

  • Hi Ryan,

    If you installed the driver from https://www.silabs.com/developers/usb-to-uart-bridge-vcp-drivers, your PC should be able to find it. Make sure you connect the USB cable to the USB Micro-B debug console on the EVM, which is right next to the USB-C connector.

    Regards,

    Jianzhong

  • Hello Jianzhong,

    I tried installing the driver from that location, but it still does not show in my device manager. I also have an AM243x Launchpad on hand and tried looking for its COM port--the same problem happens when I cannot see that the device has connected to my machine.

    I also tried plugging in the device to another windows machine with the updated driver and it didn't show--Is there some sort of configuration that needs to happen with the board(s) so that I can see it in device manager?

  • Ryan,

    Can you try a couple of things:

    1. Make sure you have a USB-C 5V 3A power supply or USB-C to USB-C cable for powering from PC. A USB to USB-C cable doesn't work.

    2. Power off the board. Go to TeraTerm to open a new connection and notice the available serial ports.

    3. Power on the board. Go to TeraTerm to open a new connection and see if there are new ports available.

    4. If you have a Linux PC or Mac PC, try it on those PCs.

    Regards,

    Jianzhong

  • I realized the problem was with the USB to Micro-USB cable I was using. After trying a different cable, both boards came up in my device manager. Thanks!