This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TDA4VM: MCU1_0 : UART test demo application

Part Number: TDA4VM

Hello,

SDK 8.0v

We are trying to develop an application that uses the UART on MCU1_0 to communicate with an external device.
While trying the UART demo application provided under the PDK we were not able to get the message echo back as mentioned in the documentation.
we are using SD card to boot the board.

We would like to know the steps to be followed to get the UART application up and running on MCU1_0.

The steps we followed

1. make -s -j BUILD_PROFILE=release BOARD=j721e_evm CORE=MCU1_0 UART_TestApp_tirtos

2.change the DM_BOOT in linux make file to point to /home/user/ti_sdk_8.0/ti-processor-sdk-rtos-j721e-evm-08_00_00_12/pdk_jacinto_08_00_00_37/packages/ti/binary/UART_TestApp_tirtos/bin/j721e_evm/UART_TestApp_tirtos_mcu1_0_release_strip.xer5f 

3. make u-boot

4. cp board-support/u-boot_build/a72/u-boot.img board-support/u-boot_build/a72/tispl.bin board-support/u-boot_build/r5/tiboot3.bin /media/$USER/BOOT

5. sudo cp /home/user/ti_sdk_8.0/ti-processor-sdk-rtos-j721e-evm-08_00_00_12/pdk_jacinto_08_00_00_37/packages/ti/binary/UART_TestApp_tirtos/bin/j721e_evm/UART_TestApp_tirtos_mcu1_0_release_strip.xer5f /media/$USER/rootfs/lib/firmware/j7-mcu-r5f0_0-fw

6. sudo cp /home/user/ti_sdk_8.0/ti-processor-sdk-rtos-j721e-evm-08_00_00_12/pdk_jacinto_08_00_00_37/packages/ti/binary/UART_TestApp_tirtos/bin/j721e_evm/UART_TestApp_tirtos_mcu1_0_release_strip.xer5f /media/$USER/rootfs/lib/firmware/pdk-ipc/UART_TestApp_tirtos_mcu1_0_release_strip.xer5f

LOG: