This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

AM3352: Having problems removing packages & files from the root fs build

Part Number: AM3352


We're developing a board that has no graphic or video output, so we don't need QT, weston, etc. We also don't need the http server (thttpd or lighttpd) or USB support.

I'm having problems finding the correct location & syntax to remove the packages and kernel features.

I've tried many web searches but none of the suggestions work. For example, in our ".conf" file I tried both
   IMAGE_INSTALL_remove += "thttpd"
   IMAGE_INSTALL_remove += " thttpd"
but that didn't have any effect. The file "/usr/sbin/thttpd" is always included in the created image and the service is always started.

We're using processor-sdk-

Any help would be appreciated.



  • Hi Scott,

    I've tried many web searches but none of the suggestions work. For example, in our ".conf" file I tried both

    Is this in Yocto config? Which ".conf" file is this?

  • Hello,

    I've tried changes in our product specific files "layers/meta-product/conf/machine/product.conf" and "layers/meta-product/conf/layer.conf". Yes, they should be a Yocto configuration file. This file contains many configuration specifications like SERIAL_CONSOLES, KERNEL_IMAGETYPE, KERNEL_DEVICETREE, UBOOT_ARCH, UBOOT_MACHINE, etc.


  • Scott,

    I am routing your query to our Yocto expert for comments.

  • Hi Bin, Were we able to close with Scott on this?  Email me offline if you want help to chase down the Yocto team member.

  • Hello Blake,

    Has the customer taken a look at our "building the SDK" documentation? It covers several areas you mentioned, like removing wayland, graphics, etc.



  • Thanks Nick, 

    We'll let you know if this works for us!  Let's give Scott a week to plough through the docs and see if he has success, after that we can mark it complete.


  • Hi Nick,

    That documentation is a good start but has the same issue as the results from web searches. Yes, the changes work if you know which *_remove variable to use for each component you want to remove. However, changes to the file conf/local.conf can't be checked in or shared because it's a local file that isn't in the git repository. In other words, if I make changes to that file I can't push the changes and someone else won't see the changes.


  • Hello Scott,

    If you need to have your changes under version control, please take a look at the oe-layersetup project. under sources/meta-ti/conf/machine you could add a custom machine with your custom settings.

    e.g., am335x-evm.conf includes include/ In MACHINE_FEATURES includes gpu. If you remove gpu for your build, then the QT & Weston parts of the yocto build will not occur.

    Another team member pointed out to me that there might be some bitbake recipes that you would want to edit under meta-arago as well (e.g., 



  • Hello Scott!

    Sorry to answer to an old thread. My hunch is people are stumbling on this thread via Google and therefore I feel I need to share what I have about the subject.

    I had exactly the same problem as you, I was struggling with removing thttpd which was messing my nginx operations.

    The thing to fix it is to create packagegroup-arago-console.bbappend and put the following in it:

    RDEPENDS_${PN}_remove = "thttpd"

    You need to figure out a way where to put this bbappend. In this project I have inherited, we have a custom layer where we build company custom software, update images, etc. I have placed the file there. After this change no more thttpd !

    root@am335x-evm:~# which thttpd
    which: no thttpd in (/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin)

    (BTW, I found the correct packagegroup file by temporarily removing the thttpd bb recipe. After that my build reported packagegroup-arago-console needed thttpd and I was able to remove it.)