This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

CCSTUDIO: CCS12 crashes when loading Project Zero on a CC1352P-4 LaunchPad

Part Number: CCSTUDIO
Other Parts Discussed in Thread: CC1352P, CC2640R2F, UNIFLASH

When trying to debug project_zero_CC1352P_4_LAUNCHXL_tirtos7_ticlang on a new CC1352P-4 LaunchPad
- CCS12 crashed at the end of the automatic firmware update of XDS110 to version
- After CCS restart, program loads but CCS12 crashes before displaying "loading symbols"

This is possibly a CCS version problem:
I do not have any issue with CCS11 Version: Clang 1.3.0.LTS or TI Clang 2.1.0.LTS)

Other information
- Advanced debug settings of CCS are identical in both CCS versions
- Debugging is ok (CCS12) with a custom board (CC2640R2F, old sdk, not clang compiler) and a standalone XDS110
- No impact of antivirus (I tried with Bitdefender off)
- Loading the program with standalone Uniflash 6.1.0(project_zero_CC1352P_4_LAUNCHXL_tirtos7_ticlang.hex) works and I can connect to the board
- Reloading XDS110 firmware ( using "xdsdfu -f firmware_3.0.0.20.bin -r" does not change anything

- Windows 10, 21H2, build 19044.1865, Pack 120.2212.4180.0
- Bitdefender Internet Security
- CC1352P-4 LaunchPad with on-board XDS110 debug probe (CC1352P1-4 Development Kit), BOM Rev A, FW SDK4.1 2029
- Project Zero from simplelink_cc13xx_cc26xx_sdk_6_20_00_29
- CCS 12 Version:
- TI Clang 2.1.0.LTS

Running eclipsec led to another error : Failed to load class "org.slf4j.impl.StaticLoggerBinder"

  • Further investigation shows that the problem disappears when changing compiler.

    Project Zero can be executed with CCS12 & TI Clang 1.3.1.LTS BUT NOT with TI Clang 2.1.0.LTS.

  • Hello,

    This is a known issue:

    Please note the workaround in the above link.



  • Hello,

    Thank you, this partially solved my issue when using Clang 2.1. I can execute the program.

    However, error "symbols are not defined" makes debugging impossible (in fact some are loaded according to Modules view).

    Here are the detailed steps I used to implement the workaround.
    1) In the Properties of the project, after showing advances settings, deselect option Debug / Auto run and launch options / connect to the target on debugger startup
    2) Launch debugger (it can not load program)
    3) Connect to target
    4) In Expressions panel, add expression symbol_loader and set it to 1
    5) Load program
    6) Resume execution (F8)
    7) Project Properties can be reset (by selecting option of step 1) not to have to connect / load program manually.

    Unless, I misunderstood something, the best workaround for me will be to use Ti-Clang version 1.3.1 for debugging until this issue is resolved in version 2.1.1.


  • Yes you are correct. Enabling the workaround is basically just using the legacy symbol manager which skips corrupted debug symbols. But of course the skipping of symbols would still impact your debug visibility.

    Yes if downgrading to compiler v1.3.x is an option, that would be the best option.