This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

SK-AM62B-P1: Cannot load Matrix GUI

Part Number: SK-AM62B-P1

Tool/software:

Hi I am evaluating SK-AM62B-P1 and trying to load MATRIX GUI to run the out-of-box demo. I have tried following guidelines however facing issues as below. It would be helpful to get some direction for this.

1. Using IP web browser, getting an error.

192.1XX.XX.XX refused to connect.

I have ping the IP address is correct, I could ping and get responses. Is there any workaround for this?

2. Running Matrix GUI from HDMI display, could not find the path:

         /etc/init.d/weston restart

         /etc/init.d/matrix-gui-2.0 start

Can you advise if the path has been updated so that I can try this way?

Link to guideline: dev.ti.com/.../node

WIC Image used: PROCESSOR-SDK-LINUX-RT-AM62X 

Thank you.

  • Hi,

    We have stopped supporting matrix-gui and from future releases, it will be removed. Any reason you are trying to run the matrix-gui application?

    Regards,
    Krunal

  • Hi Krunal,

    Is there any reason of stopping support for matrix-gui or has it been replaced with some other later application?

    My purpose is to run the out-of-box demos as mentioned in the Quick Start Guide.

    Thank you.

  • Hi Krunal,

    Thanks for that. Yes I managed to load TI Apps Launcher and run some of the demos. I have two more questions to ask for my evaluation needs here.

    1. Using existing TI Apps Launcher, is it possible to exercise a case of maximum load of GPU,CPU,Memory and observe core temperature & power consumption on power rails (ie: VDD Core, VDDR Core, Digital VDD 3.3V etc)?

    2. On TI Apps Launcher, Seva Store takes a long time and never load the Home Automation HMI: Thermostat Design apps. The page is trying to load however no response. May I check with you if this is a known issue and if there is a fix for it?

  • Hi,

    #1. With regards to power, please create another thread.

    #2. Are you behind proxy? I have only seen the above issue when I am at work and proxies are not configured.

    Regards,
    Krunal

  • Hi Krunal.

    Can you help further on how to configure the proxies?

    1. For my setup, I have my EVM board eth port connected to the router that goes to the office network. Then I run a HDMI to the monitor to launch TI Apps Launcher. When running seva store from TI Apps Launcher, it says "cannot reach the network". On TI Apps Launcher, I tried Settings-> fill in the <IP-address> for HTTPS Proxy->Set Proxy. After 1-2minutes, TI Apps Launcher then opens Wayland Terminal page, no more options to select Seva Store or any other demo pages and I cannot go on further from the screen. The only way I can get TI Apps Launcher to run again is by repowering the EVM board.
    2. On the other hand, when I access IP address from my separate laptop that connect to the same router, I saw the page is trying to load (per picture above).

    The question here that I'd probably is not so clear about is to where and how do I configure the proxy, on EVM or on my laptop?

    If there is anything else I could share to make the explanation more clear for you, please let me know. Thanks again for looking into this.

  • Hi,

    > Seva Store

    Looks like something went wrong when you were trying to apply the proxies OR maybe does your office network allow pulling from ghcr.io?

    I would encourage you to reboot your EVM once & start fresh.
    You can follow the steps mentioned here - Seva Store - User Guide

    Step 1 - Ensure that you see an IP on bottom left corner of TI Apps Launcher.

    Step 2 - As you are working behind proxies, go ahead and use the Settings Tab that automatically applies the Docker & Environment proxies needed for Seva Store to run. After hitting Set proxy, you should see a green text saying Proxies applied successfully. To confirm, try pulling a container from ghcr.io,

    docker pull ghcr.io/texasinstruments/app_thermostat_demo:latest


    If the above command works, we can rule out the "office network blocking ghcr.io" issue

    Step 3 - Refer step 3 from Click on the Seva Store button from the Left Hand Side Menu

    Note:
    The Thermostat Demo Docker Image that we provide is around 800 MB. 
    Hence, docker pull time may vary based on your network speed provided to EVM.

     

  • Hi Chirag,

    Thank you for the instructions. It seems like there is something blocking to continue further from Step 2. Does this tell us that my office network somehow is blocking this ghcr.io? And what is the solution to resolve this?

    Step 1 - Success, I can see the IP address

    Step 2 - No success, as I hit Set proxy, I do not see the green text saying Proxies applied successfully but the apps open Wayland Terminal Page straight away so I could not tell if it has been set successfully. 

    When trying the docker pull ... command, the response is per follow: proxyconnect tcp: dial tcp <IP_address:80:> connect: connection refused

     

  • Hi,

    > I do not see the green text saying Proxies applied successfully but the apps open Wayland Terminal Page straight away 

    Looks like something is incorrect in the way the inputs are passed to Settings tab which is resulting in TI Apps Launcher to stop unexpectedly.
    What's the input you are providing?

    The expected input format are,

    HTTPS Proxy - A single proxy URL (eg - http://socks.example.com:1080)

    NO Proxy - list of comma separated domain names (eg. ti.com,google.com). This field can be empty as well.

    Are your inputs in the above format?

    I tried with our TI network proxies & the TI Apps Launcher is able to set it correctly.



    > When trying the docker pull ... command, the response is per follow: proxyconnect tcp: dial tcp <IP_address:80:> connect: connection refused

    This error confirms that docker proxies were not set successfully.



    > Does this tell us that my office network somehow is blocking this ghcr.io? And what is the solution to resolve this?

    To comment on this we first need to get the docker proxy settings applied on your EVM. Can you confirm on the inputs that you provided in TI Apps Launcher Settings Tab?

  • Hi Chirag,

    I can see the green text saying Proxies applied successfully now with the reference example. It was a missing port no when I specified the proxy.

    Doing the following solve the issue:

    HTTPS Proxy - https://192.168.15.xx:xxxx

    NO Proxy - empty

    With the docker pull, I am getting this message, may I check what's missing for this?

    root@am62xx-evm:~# docker pull ghcr.io/texasinstruments/app_thermostat_demo:latest
    Error response from daemon: Get "">https://ghcr.io/v2/": proxyconnect tcp: tls: first record does not look like a TLS handshake

  • Hi,

    > Error response from daemon: Get "">https://ghcr.io/v2/": proxyconnect tcp: tls: first record does not look like a TLS handshake

    This happens when your network proxy doesn't support HTTPS. Is https://192.168.15.xx:xxxx a valid proxy configuration for your office network?

    If not I would recommend to enter http://192.168.15.xx:xxxx in Settings & try to reapply the proxy configuration.

  • Thank you Chirag, with  http://192.168.15.xx:xxxx. works and I can browse on Google webpage from seva store and Chromium.

    I believe that shows Proxies applied successfully?

    However, with launching the thermostat, I'm seeing this from docker pull and on Seva store page, it is Loading...

    root@am62xx-evm:~# docker pull ghcr.io/texasinstruments/app_thermostat_demo:latest
    Error response from daemon: Get "">https://ghcr.io/v2/": proxyconnect tcp: dial tcp: lookup http on 192.168.4.10:53: server misbehaving

  • additional to that, docker info show these warnings

  • Hi,

    > I believe that shows Proxies applied successfully?

    Yes, this confirms that network proxies were applied correctly.


    To confirm on docker proxies you can also check the output of,

     

    sudo systemctl show --property=Environment docker




    > root@am62xx-evm:~# docker pull ghcr.io/texasinstruments/app_thermostat_demo:latest
    Error response from daemon: Get "">https://ghcr.io/v2/": proxyconnect tcp: dial tcp: lookup http on 192.168.4.10:53: server misbehaving

    It looks like your office network has blocked pulling docker images from ghcr.io
    I would recommend you to check with your organization's network team on whether they allow pulling containers from ghcr.io, docker hub.

    BTW does the following work for you on your EVM,

    docker pull hello-world

  • Perhaps so. docker pull hello-world is returning the same Error response.

    I am checking with my IT team on the side and will keep you posted. Thanks for your help until now.