This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

Failed to boot kernel with PSDK 3.01.00.06 on K2L EVM

Hi experts,

I'm trying to run linux on K2L EVM with the latest PSDK package. Now i can run uboot but failed to start kernel with the ubi image in the package.

1. I tried both arago and tisdk based ubi image. No one worked.

2. I tried burn ubifs image in uboot and using program_evm.js. No one worked.

I'm sure the uboot and ubifs image are the same version from the latest package. As below please check my boot log. Please kindly give me your advices or comments. Thank you.

#################################################################
#################################################################
##################
1.2 MiB/s
done
Bytes transferred = 418381824 (18f00000 hex)
=> run burn_ubi

NAND erase.part: device 0 offset 0x180000, size 0x7fe80000
Skipping bad block at 0x00840000
Skipping bad block at 0x40180000
Skipping bad block at 0x42a40000
Skipping bad block at 0x46380000
Skipping bad block at 0x57b80000
Skipping bad block at 0x5ebc0000
Skipping bad block at 0x6d340000
Skipping bad block at 0x6e140000
Skipping bad block at 0x779c0000
Skipping bad block at 0x7ba40000
Skipping bad block at 0x7ff00000
Skipping bad block at 0x7ff40000
Skipping bad block at 0x7ff80000
Skipping bad block at 0x7ffc0000

OK

NAND write: device 0 offset 0x180000, size 0x18f00000
Skip bad block 0x00840000
418381824 bytes written: OK
=>
U-Boot SPL 2016.05-g2f757e5b2c (Oct 03 2016 - 21:39:40)
Trying to boot from SPI


U-Boot 2016.05-g2f757e5b2c (Oct 03 2016 - 21:39:40 -0400)

CPU: 66AK2Lx SR1.0
I2C: ready
DRAM: DRAM: 2 GiB

Clear entire DDR3 memory to enable ECC
2 GiB
NAND: 2048 MiB
Net: eth0: netcp@26000000
Error: netcp@26000000 address 2b:a1:77:00:7c:66 illegal value

Warning: netcp@slave-1 (eth1) using random MAC address - 6a:88:3e:a2:72:07
, eth1: netcp@slave-1
Warning: netcp@slave-2 (eth2) using random MAC address - 1a:93:b6:bd:c5:a0
, eth2: netcp@slave-2
Warning: netcp@slave-3 (eth3) using random MAC address - da:4b:73:90:57:ae
, eth3: netcp@slave-3
Hit any key to stop autoboot: 0
ubi0: attaching mtd1
ubi0: scanning is finished
ubi0: volume 0 ("rootfs") re-sized from 1594 to 8022 LEBs
ubi0: attached mtd1 (name "mtd=2", size 2046 MiB)
ubi0: PEB size: 262144 bytes (256 KiB), LEB size: 253952 bytes
ubi0: min./max. I/O unit sizes: 4096/4096, sub-page size 4096
ubi0: VID header offset: 4096 (aligned 4096), data offset: 8192
ubi0: good PEBs: 8172, bad PEBs: 14, corrupted PEBs: 0
ubi0: user volume: 1, internal volumes: 1, max. volumes count: 128
ubi0: max/mean erase counter: 1/0, WL threshold: 4096, image sequence number: 112838
ubi0: available PEBs: 0, total reserved PEBs: 8172, PEBs reserved for bad PEB handl6
Error reading superblock on volume 'boot' errno=-22!
ubifsmount - mount UBIFS volume

Usage:
ubifsmount <volume-name>
- mount 'volume-name' volume
UBIFS not mounted, use ubifs mount to mount volume first!
ubifsload - load file from an UBIFS filesystem

Usage:
ubifsload <addr> <filename> [bytes]
- load file 'filename' to address 'addr'
=>

Regards,

Allen