• Resolved

CCS/DRV8881EEVM: drv 8881eevm Software

Intellectual 775 points

Replies: 32

Views: 1250

Part Number: DRV8881EEVM

Tool/software: Code Composer Studio

I bought a EEVM 2 months ago and just can't get it to work since; this despite help from TI engineer. Just cannot install the software. Instruction manual does not help e.g. where it says install from web or install from file, I tried both options separately - no luck. Then when it gives 4 options to check (fig 16) I get only get 3, the last one launch I just don't get. So I end up with the icon on my desktop which doesn't work; when clicked it asks for the exe file and that's the end of it! Does anyone know how this works?

  • Ken,

    Yes. This issue takes too long, even with couple webex meetings. The network speed is not consistent and cannot support WebEx very well.

    Right now, you have downloaded the "runtime".  Please copy the "runtime" path. For example: copy "C:\Users\a0132932\Downloads\gcruntime-7.0.0-windows-installer.exe" and paste it in "Install from file" window as the following picture.

    Please let me know if you still have a trouble after done this. For long run, I do think you have to find a local support to assist you that could speed up the support.

    Best Regards,

    Wang Li

    Motor Drive Solutions

  • In reply to Wang5577:

    Hi Ken,
    This particular EVM GUI has been created quite some time ago. It is a bit tricky to find the correct version of GC Runtime. We have made some improvements where we have a website where an app and its matching runtime are shown on the same tile. This eliminates the confusion of which runtime to use. However, this particular app was published before this website was available. Gcruntime-7.0.0 is very recent and it will not work with GUI that you are trying to use.

    Link to a different post below has more information on a slightly different DRV app, but the same runtime will work with this app. Please see my answer in this other post on how to get the right runtime.

    Just fyi... Download option may not work well in scenarios where there are corporate proxies configured. Once this is installed you should be able to start the GUI by double clicking on this .bat file C:\Users\YourWindowsUserAccount\guicomposer\runtime\gcruntime.v2\DRV8881EEVM\win32_start.bat

  • In reply to MartinS:

    Thanks Wang and Martin for your replies. 

    I tried putting in the file path for runtime i.e. C:\Downloads\gcruntime-7.0.0-windows.installer.exe - no change same problem as before, only 3 options in fig 16 i.e. no launch. As far as Martin's post, could not really understand it i.e. can it work or not? so many variations not sure where to start. So after 2 webexes (phone cost to me @ $50) still no solution. I agree with Wang that network was slow on our webex of 30/1/19 but that was because of a severe snowstorm here. The first webex 26/12/18 was fine.

    So the upshot of it all is that I have an expensive paperweight (EEVM).

  • In reply to ken dias:

    Hi Ken, 

    My apologies for unclear instructions. gcruntime-7.0.0-windows.installer.exe is the wrong version of runtime. The other post that I referenced has a link to correct version. I have also pasted below as well. The link might look like a picture

    Please try using this runtime during installation. The path to run the executable should be pretty much the same as I mentioned in my previous post, except your user id. i.e. something like USER_HOME\guicomposer\runtime\gcruntime.v2\DRV8881EEVM\win32_start.bat  Desktop shortcut should be pointing to this file. 



  • In reply to MartinS:

    Thanks Martin.

    Clicked on the pic you sent; it installed gcruntime.v2 in c:\users\admin\guicomposer\runtime. Carried on with install, when asked for load from file, I put in c:\users\admin\guicomposer\runtime\gcruntime.v2. Got error msg that this is not a file but it carried on installing with the same result as before i.e. does not work

  • In reply to ken dias:

    You mentioned .bat file but could not find it
  • In reply to ken dias:

    Still waiting for an answer

  • Part Number: DRV8881EEVM

    Tool/software: Code Composer Studio

    I have a problem outlined in the previous forum - shows answered but not answered

  • In reply to ken dias:

    Hi Ken, 

    Let's try from beginning, here are the steps that I am taking. 

    Download slvc628.zip, extract it, go into GUI folder and extract DRV8881EVM_installer.zip to a new folder. There should be two files there,  an exe and .zip, they both should be in the same folder. Then you would run .exe 

    The page of installer program where GC Runtime needs to be installed allows to install from the web or from a file. In both cases application installer is trying to run child GC Runtime installer, main difference is that first option tries to download from TI server and second option allows user to provide an already downloaded GC Runtime executable. The DRV8881EVM application installer will then invoke the GC Runtime installer to actually install the runtime. i.e. you do not need to point it to an already installed directory. 

    The path that I mentioned in my previous post assumes that you installed in default directory, if you chose a different directory to install then paths will be different. 

    If you are able, could you also send me installer log? It should be located in TEMP folder and it is called "bitrock_installer.log" I would be pick the most recent one, if there are multiple. The simplest way to go to TEMP directory is to open Windows Explorer and in address bar enter "%TEMP%". You could open log file in a text editor and check whether it is the log file for correct application as it should have text appearing as below. 


    rying to init installer in mode win32
    Mode win32 successfully initialized
    [08:15:35] gc_major = 2
    [08:15:35] run time version required: 2.0.3
    [08:15:35] zipfile name is now install_image_DRV8881EEVM.zip
    [08:15:35] Installing install_image_DRV8881EEVM.zip

  • In reply to ken dias:

    Hi Ken,

    This post was merged with the rest of the thread. The thread is still active until you confirm it is resolved. Martin has replied below above.

    Rick Duncan
    Motor Applications Team