This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

LMX2594EVM: LMX2592EVM, LMX2582EVM registers not loading

Part Number: LMX2594EVM
Other Parts Discussed in Thread: USB2ANY, LMX2594, LMX2592,

I am operating system that contains all three of the above components. As of yesterday they were all operating as expected, however this morning they no longer output a signal.

All three devices are operated through the TICS Pro and interface with my computer through the USB to any devices.

I have tested power cycling and reloading the registers through TICS Pro, however there is still no output form any of them. In addition when I use TICS Pro to read back the raw registers they all come back as empty leading me to believe that the registers are not loading properly when I submit them through TICS Pro.

The only commonality between the devices, other than the fact they are all connected to the same computer, is that they share a power line.

  • Hi Andrew,

    Could you probe the SPI bus to see if there are signals coming out from the USB2ANY?

  • Hi Noel,

    A quick amendment to my original post. Upon further inspection of my boards and the user guide it appears that the reason I am reading empty registers when I read back with TICS Pro is because I did not move the position of the appropriate resistor.

    As for your question. I could not see any test points labelled as SPI bus, however I did check every test point on one of the LMX2594 and LMX2592 boards. The only test point that provided any output signal was that for the input clock signal. Hopefully this answers the question.

  • Hi Andrew,

    so in fact you can write and read the registers without issue?

    SPI bus means the SDI, SCK and CS# signal, we have test points for these signals. If you can write and read registers, then there is no need to probe these signals. 

    Is there no signal output at all or the output frequency is not correct? If it is the later, is the reference clock still alive? If you can program the devices, even if they do not lock, there will be signals coming out from the devices. If you get nothing, the only possibility I can think of is the power supply is having issue.

  • Hi Noel,

    It is more that I don't know if I can read or write registers as I do not have readback enabled on my boards, and changing this is a fairly involved process due to their position in the system.

    As for your question, I have no output at all from any of the boards. I have checked the input clock, the power was lower than previous so I have both tried amplifying this signal and tried an alternative with no success. I have tested a board on an alternative power supply to no effect.

    I do however have some new information. I was able to source some spare LMX2594EVM boards from a colleague and attempted to interface one of these with my system as well, both with integrated power/clock/USB2Any and external power/clock/USB2Any and these boards also do not provide an input. I am beginning to wonder if the issue is with the way in which I am using the TICS Pro software rather than any issue with the hardware.

  • Hi Noel,

    It turns out that the entire issue came from a series of dodgy USB cables. It isn't entirely clear to me why but none of the USB cables that I was using to communicate with the evaluation boards are now working. I got hold of a new one and these all now work. This does not explain why they all turned off or why I was able to see and seemingly communicate with the USB2Any devices (if you have an idea why then I would be very happy to hear it) but it does at least provide an issue to my immediate problem.

    Thank you for your help.