This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

CDCI6214EVM: Can't get correct clock output of CDCI6214

Part Number: CDCI6214EVM
Other Parts Discussed in Thread: CDCI6214, CDCE6214

Hi Experts,

Good day. Allow me to paste the full query of my client:

I purchase a demo board of CDCI6214,  I configured the CDCI6214 on demon board with software  TICS Pro.
When power on the demo board, device 0X76 can be found ( EEPROMSEL is configured with low level).

25MHZ is input at XIN PIN  and we can get 25MHZ at Y0,  25MHZ can be seen at Y0 PIN.
Y1P/Y1N,   Y3P/Y3N,   Y3P/Y3N are configured to output 125MHZ,  But we got 142MHZ. 
Y2P/Y2N is configured to output 100MHZ,  But we got 110MHZ.

I am confused what is the matter?

Question 1:  in TICS Pro software,  there are four places  which are used to enter target frequency, but I can't enter my target frequency.
Question 2:  when I click RE-CAL,  it will remind  "Error while writing into Register  R0, R37..."

I attach my configuration by attachment.

Could you please help me to check what is the problem with CDCI6214?

Thank you for your guidance.

Regards,
Archie A.

GE104_CLOCK_CDCI6214_202201011.7z

  • Hi Team,

    Any update on this?

    Sorry but client is pushing for follow up.

    Looking forward to hear your thoughts on this.

    Thank you.

    Regards,
    Archie A.

  • Hi Archie,

    Sorry for the delay. The configuration looks fine. "Error while writing" is because I2C address is not correct or did not scan I2C bus. There's a simple frequency calculator in CDCE6214 but for CDCI6214 it doesn't work unfortunately so frequencies need to be set manually.

    Please make sure to follow below 3 steps in sequence: (1) scan I2C bus (2) write all registers (3) click recal.

    Regards,
    Hao