This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

CDCM6208: LOS of reference when only PRI_REF used

Part Number: CDCM6208

Hi, all!

I encountered a problem with this device:

In my board, PRI_REF pin is connected to a LVDS  transmitter working at 100 MHz. SEC_REF pin(also VDD_SEC_REF) is directly connected to GND so it is not used.

REF_SEL pin is set to low because I only use PRI_REF. SYNCN and PDN pins are both float.

I programmed it with SPI mode and set Reg.4 as 0x338C. The device gave me the information that LOS_REF is high and the PLL is unlocked, of course, there is no output.

The input clock is normal, also the output clocks at Y4&Y5 when I set Y4&Y5 to bypass PRI_REF.

I wonder why there is no output clock of SMUX. Did I make the wrong configuration?

  • Hi weit20,

    I reviewed R4 = 0x338C and the settings look OK. You may try setting bit #12 = 0 just in case. Currently it is 1, which is telling the device to use SEC_REF unless REF_SEL is low, and I do not know how consistent the override is.

    If the smart mux is configured correctly, it is possible that the reference signal is being passed into the PLL, but something about the PLL settings is preventing the device from locking. I think this has happened to other customers in the past. If you used TICS Pro, please provide us the configuration file (.tcs) so we can look at the other registers. Or if you generated the register configuration by hand, just list them here.


    Evan Su

  • Hi Evan,

    I have tried to set R4.12 = 0, but it still does not work. 

    The attached file is my configuration file.


  • I also provide the screenshot of TICS Pro.  

  • Hi weit20,

    The PLL configuration generally looks correct. I noticed that the ENCAL field (bit #4 in Register 3) is disabled for some reason, which may prevent the VCO from starting properly after a configuration change. It is enabled in the default configuration, so I would recommend going to User Controls --> Control Signals and enabling ENCAL. I think this change will automatically calibrate the VCO, but you can also toggle the RSTN register (bit #6 in Register 3) from 1 --> 0 --> 1 just in case you don't see anything immediately. Let me know if it helps.


    Evan Su

  • Hi Evan,

    I did as what you recommended and now it works properly. Thanks for your help.


    Tong Wei