This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

CDCI6214EVM: ticspro issues

Part Number: CDCI6214EVM
Other Parts Discussed in Thread: CDCI6214, USB2ANY

Hello,

I am trying to get my cdci6214evm running via the quickstart guide. However, my ticspro does not appear to have a find device button as stated in the guide. When i push the power off button to change it to power on I get an error saying no device connected, and I am unable to get ticspro to find the device. I tried reinstalling tics pro and got the following error: 

Internal error: expression error ‘Runtime Error (at 97:71):

 

List index out of bounds.’

I am still able to open tics pro despite the error, but I still can't get it to recognize the evm is connected. Do you have any advice on how to deal with this?

Thanks for the support!

Best,

Adam Daluga

  • Dear Adam,

    thank you for your patience. I sent a request to provide answer for this request.

    Regards, Simon.
  • Hello Adam,

    thanks for highlighting. The public software never contained a Find Device button. The GUI automatically searches for I2C connection when you power up while the reset button shows "high" state (or you toggle reset while power button is on).

    Can you please do the following and let me know what happens, as I cannot reproduce the error you are seeing:

    Disconnect the EVM. Ensure that only one LDO/DC switcher is selected when you power from USB.

    Start TICS Pro, select the CDCI6214 and close TICS Pro.

    Go to the following directory and delete any *.tcb file which is there:

    C:\ProgramData\Texas Instruments\TICS Pro\Configurations\Devices\Clock Generator-Jitter Cleaner (Single Loop)\CDCI6214

    Connect the EVM. The LED next to the MSP430 should be constantly lit.

    Then start TICS Pro again. You should see this config loaded.

    Click the button showing you the "pwr off" status, it will change to "pwr on".

    Please let me know the content which you see in the status bar of the software (on the bottom left) - are there any error messages?

    Thanks!

    Best regards,

    Patrick

  • Hello Adam,
    do you have additional feedback which would help to reproduce your observation?
    Thanks!

    Best regards,
    Patrick
  • Hello Patrick,

    Sorry for the delay. I went through the steps you advised and still got the no device found error box. The .tcb file that i delete returns after I run TICSPro even though I deleted it before running the program. 

    The LED does stay lit like you said it would. 

    Here is the output from TICSPro, let me know what you think the next steps are. Thanks for all the support!

     

    Welcome to TICS Pro. Version -> 1.6.7.0, 16-Mar-18

    Loading Device CDCI6214…

    Detected 1 USB2ANY interfaces

    Error while writing into Register R15

    Error while writing into Register R60

    Error while writing into Register R61

    Error while writing into Register R62

    Error while writing into Register R59

    Error while writing into Register R59

    Error while writing into Register R59

    Completed loading Device CDCI6214. Version = 2017-10-26

    Scanning for I2C address…

  • Also, what position should the switches for S2 be in on startup?
  • Hello Adam,
    thanks for the online session. Please let me know when you have any further need for clarification!

    Best regards,
    Patrick