This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TI-API: Having issue in getting product information using API

Part Number: TI-API
Other Parts Discussed in Thread: TM4C1294NCPDT

Hi Team,

Thank you for the quick response. 

I tried with other part numbers. still I am getting the same error.



"fault": {
"faultstring": "Invalid API call as no apiproduct match found",
"detail": {
"errorcode": "keymanagement.service.InvalidAPICallAsNoApiProductMatchFound"

Could you please let me know which URL i have to use to access product, Qty and price information

Kind Regards

Ameenullah Samiullah

  • Hi Ameenullah,

    There are a couple of things to point out:

    1. Part LM336Z-5.0 cannot be found in our catalog, but, we do offer an alternate part (LM336Z-5.0/NOPB ), that you may be able to consider.  Alternate parts can be found on the product page, when you conduct your searches (see example below for this part).

           2.The syntax around the client_id and client_secret is incorrect.  Please remove the single quotes and try again.  (see below)  If you encounter any additional issues with authentication, you can reference the Authentication page or submit another E2E and we'll be glad to assist.

    Please let us know if you need anything else.



  • Hi Faye,

    I dont have issues in Authentication, I am getting the access token. I checked again for quotes, its correct. 

    This product is working : TM4C1294NCPDT

    Sandbox( with -pre))

    Its not working (without -pre) ..

    Please check.

    Kind Regards


  • Hi Ameenullah,

    Thank you for the additional information.

    The account that you are using does not have access to our production APIs.  You have multiple accounts and only one of your accounts has access to the production Store APIs.  Please be sure to consistently use the account that has been successful, and, there is no "sandbox" concept with this account.   You will always be pulling the information from the production environment.  Please accept my friend request so we can discuss further, and help you with what you need.  



  • Hi, I found the error. In my curl request, I removed few header info. it start working. thanks anyway.

  • Ameenullah,

    Great!  I'll close this thread.



**Attention** This is a public forum