This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

Unable to get Stellaris Launchpad recognized by PC

Other Parts Discussed in Thread: EK-LM4F120XL, MSP430G2553, EK-TM4C123GXL, TM4C123, ENERGIA, TM4C123GH6PM, LMFLASHPROGRAMMER

I felt great excitment when I plugged in my new Stellaris Launchpad to my PC: pushing buttons and seeing the lights change, and even more when I read that I could control it through a PC terminal. However, I have not been able to get the Stellaris Launchpad recognized by the computer, when I plug it in, nothing happens on the device manager, no driver wizard, no new device found, nothing. I have tried with both Windows 8 Release Preview (yes, I disabled driver signature enforcement) and Windows 7 Professional 64 bits. The only thin I could get was device manager listing a "Stellaris Firmware Upgrade" device when removing the VDD jumper and plugin in the board:

Any advice is welcome, thanks.

  • Jose,

    Have you gone through the steps in the Stellaris Driver Installation Guide found here?  Windows 8 is very much like Windows 7 when it comes to installing the Stellaris ICDI drivers so follow the Windows 7 instructions.  Ensure that the USB cable is connected through the Debug Active USB port and the switch is the in the Debug position when trying to connect to the PC for the first time.

    It sounds like you're connecting to the Device USB port.  When connecting through this port after installing the Stellaris ICDI drivers through the Debug Active USB port, point the Windows driver installation wizard to the windows_drivers folder in StellarisWare.

    -Rebecca

  • Yes, the USB cable is connected through the Debug port and the switch is in the Debug position.

    As the driver installation guide suggests, when plugging the board the OS should launch the new hardware found wizard, however, it does not, neither the device manager lists anything. Today, I tried with a XP 32 bits installation, same results: device manager does not recognize anything unless I remove the Vdd jumper from the board (and plug it in connected to the Debug port), only then I get a "Stellaris Device Firmware Upgrade" device listed. I'll try with the second board I bought and let you know the results.

  • I've just tried with my second board, and this one works as expected, three new entries listed in Device Manager:

    And after disabling Windows 8 "signed driver enforcement" and installing the drivers:

    So, I really think there is a problem with my first board. Maybe the debug chip does not have the correct firmware? Where could I get some help with this? Thank you so much for any comment.

  • I have the same problem as you, with your first board, Jose Jorge Enriquez... Did you found out anything about it? 

    Any help guys?  

    Thanks in advance....

  • Jose,

    I will get in touch with you offline and we'll see if we can resolve this issue.

    Aggelos,

    How are you connecting the LaunchPad to the PC?  Ensure that the switch on the LaunchPad is in the Debug position, that the USB Micro-B plug is connected to the Debug USB port on the LaunchPad, and that the USB-A plug is connected to an available port on your PC.  Do you see the 'Stellaris Device Firmware Upgrade' driver in Windows Device Manager in this configuration, or do you see the three In-Circuit Debug Interface drivers?

    -Rebecca

  • Rebecca,

         I connected the LaunchPad, with the way that you discribed me... I tried one more time, for sure, and the results were the same... 'Stellaris Device Firmware Upgrade'

         I tried also to connect it on another PC, and the results were the same... What should we do?

    Thank you

  • I had the same problem with my computer not recognizing both of my boards at all, but it turns out that the micro USB cable I was using (from a phone) was the problem.  I plugged in one of the micro USB cables that came in the box with the board and all is fine.

    I did have to Disable Driver Signature Enforcement in Windows 8 x64 and then manually update the drivers by following these instructions http://www.pcpro.co.uk/blogs/2012/08/06/getting-older-drivers-to-work-in-windows-8/

  • I am having the exact same issue. It wouldn't even install any drivers when I plugged in either of my Stellaris devices to my machine. Windows 7 X64, Windows 8 X64, and Windows XP all see it as the debug instead of the normal 3 device set.

    This is happening with both of my boards.

  • We are currently in the process of investigating this issue.  I will post any results on this thread.

    Aggelos and Christian,

    I will be contacting you offline.

    -Rebecca

  • I want to add that I am waiting for a solution to this problem.

    I have 2 Stellaris Launchpads and both exhibit the same problem.

    On my development PC with all the TI CCS and Stellarisware installed
    the device manager reports:-
    Ports (COM & LPT)
        Stellaris Virtual Serial Port (COM5)
    Stellaris In-Circuit Debug Interface.
        Stellaris ICDI DFU Device
        Stellaris IDCI JTAG/SWD Interface

    On another PC, and a net-book:
    the device manager reports:-
    Other devices
        ? In-Circuit Debug Interface.
        ? In-Circuit Debug Interface.
        ? In-Circuit Debug Interface.
    and the device manager will not recognise any driver from 'windows_drivers'
    folder taken from Stellarisware.

    All 3 PCs are running XP (SP3) 32 bit.

    The USB cable is plugged into the debug (top) connector and the switch
    is in the debug position.

    Without a solution to this problem I have wasted a lot of time, and the
    boards are useless.

    Ray.

  • I have noticed that my development computer will only see 1 device "In-Circuit Debug Interface" but if I forward that device to a VMWare Guest running Windows XP, three devices appear and can install from the drivers.

    Host is Windows 7 X64, guest is Windows XP Pro (X86)

    My Windows 8 Pro X64 laptop will see all three and install drivers properly, as will XP, but the host Windows 7 machine only sees the one device. I have also verified that only one device is seen in Linux when it is booted into Ubuntu 12.4LTS.

  • I have the exact same issue. I had a very long wait for this board and it is basically useless at the moment. I connected the device to a computer running XP with the cable from the box, the dmo runs, but I get absolutely no prompt for driver install. I've tried another cable, with the same result. I've then tried my work laptop (Windows 7) and the device is not detected. I've then used a VM in VMWare on the same laptop sunning a different XP install (SP3) and it also does not detect the device.

    If I remove the jumper, or turn on with the reset button held down, I get prompted to install the "Firmware update driver".

    This is really frustrating, has anyone not found a solution yet? The fact that the firmware update driver is detected makes me believe the cables are sound.

  • Make sure you have the same issue I described at the beginning of the thread, I got it solved with help from Rebecca Ringhof, wait for her to contact you.

  • Hi Jose, I am 100% sure it is the same issue. I have tried 2 Windows 7 machines now (64bit Lenovo Thinkpad, 32bit MacBook) and a Windows XP laptop as well as a VMWare Virtual Machine running XP SP3. 

    If I plug in the Stellaris with the supplied lead, the demo runs, but I am never prompted to load drivers. If I turn off the power and hold the reset button down (and keep holding it) whilst turning on the power, I am prompted to install the Firmware Update driver, which I did under XP and it seems to appear in device manager as expected. I can also get the same to happen by removing the jumper. 

    Other than that, it never asks to install drivers. As I've tried 3 different physical machines now, I think the issue is with the hardware and seems to be as you experienced. 

    Edit: if there is something simple to try, like using a different lead or te flashing somehow, I'm happy to give that a go. Rebecca has yet to get in touch and as I got the device at the preorder price, I'm happy to hack it if you know what I need to do to fix it. 

  • Raymond,

    Sorry for the delayed response.  On the development PC, those are the drivers that you should expect to see when your LaunchPad is plugged in using the Debug USB port.  In order to download the drivers for the other PC and the netbook, you should follow the Driver Installation Instructions and download the Stellaris ICDI drivers here.  The drivers for the Stellaris ICDI are not found in the windows_drivers folder in StellarisWare.  Use these Windows drivers when using a StellarisWare example like usb_dev_bulk (see the example's readme instructions).

    Matt,

    Connect your LaunchPad with the included USB cable to the Debug USB port and the PC (make sure the switch is in the debug position and the jumper is populated):

    1. If the drivers have not been downloaded and installed using the instructions outlined in the Driver Installation Instructions document, you should be able to see three "In-Circuit Debug Interface" devices in the Other Devices section of the Windows Device Manager.

    2. If the drivers have been installed correctly, you should see the "Stellaris Virtual Serial Port" under the Ports (COM & LPT) section, and the "Stellaris ICDI DFI Device" and the Stellaris ICDI JTAG/SWD Interface" under the Stellaris In-Circuit Debug Interface.

    3. If "Stellaris Device Firmware Upgrade" appears under the Stellaris Device Firmware Upgrade section of the Windows Device Manager, then there may be something wrong with your LaunchPad's ICDI firmware.

    Do any of these three cases describe your situation or is it something else?  Can you provide a screenshot of your Windows Device Manager?

    -Rebecca

  • Rebecca,

    Unless I manually install the drivers, they are never installed. The device is never detected, Windows never asks to install the device and the device does not appear at all in the Device Manager under Windows XP (SP3), Windows 7 (32bit, booted under BootCamp on a Macbook) or Windows 7 (64bit). I've now tried a laptop using Vista also with no luck. I have also tried a number of Micro USB cabled (the supplied one, one that came with a Nokia phone, one that I use to connect an old N810 to my PC and the cable that came with my Nexus 7. All work for data it would seem.

    To answer you questions:

    1) Yes, I downloaded them day 1. The instructions assume the device has been detected, as it has not it is almost impossible to follow them. There is no "other" section under XP and there appears to be no section under Windows 7 also (the actual device manager is extremely similar.)

    2) Well, no they haven't. Because the instructions assume the device has been detected and it has not. I have manually installed the drivers by choosing "have a disk" and selected the driver directory. But all I get is the nodes in the tree with yellow explanation marks, so the device is not being detected and the drivers do not believe the device is present or correctly functioning.

    3) I only get the "Stellaris Firmware upgrade" if I remove the jumper (R17?) and turn the device on. Doing this is the absolutely singular time the Stellaris asks to install a driver, the driver installs and appears correctly in the device tree with no errors.

    I don't think any really describe my case. The simple fact is that, since opening the box and unpacking the device and plugging it in with the supplied cable, it has never been detected by any version of Windows across 4 machines and 4 versions of Windows. It was imported to the UK, the box arrived in one piece, but the board had been bouncing around inside the black internal product box, as some of the header pins were slightly bent and I had to visually inspect them and slightly bens at least one back so that ir wasn't shorting out the connection. It is entirely possible something else broke, though having looked at the board, I can't see any damage.

    Throughout all of this, the demo program has been running, the buttons seem to work and the LED's light up and cycle as described. So the device, other than the actual ICDI driver issue as discussed above, does sem to be functioning.

    What is the next step? Returning the device to you at my own expense is probably not cost effective for me. Is there another avenue we can go down before I give up and go with another ARM Microcontroller vendor? I'm happy to explore any resolution that doesn't put me further out of pocket.

  • Regarding the device manager picture - as the device does not ever appear, I'm not sure it will really help us get to the cause of the issue.

    I've uninstalled a bunch of software on the XP box to see if I can find the specific cause. Nothing so far has helped. I installed a USB sniffer and turning on the device generated USB traffic, but it#s too late here to delve any deeper.

    One other point, all of these computers have no legacy com ports, does that have anything to do with the issue?

  • Matt,

    It looks like you are experiencing the same issue that Jose had.  Some Stellaris LaunchPads have been accidentally distributed with incorrect Stellaris ICDI firmware.  We have gotten in touch with the manufacturer to remedy this issue.  Only a few LaunchPads should be affected and it looks like yours was one of them.  I will get in touch with you offline about how to resolve this issue.  Sorry for any inconvenience this may have caused.

    -Rebecca

  • Hi Rebecca,

    with my two Stellaris LaunchPads I have same problems (no changes in Device Manager on LaunchPad connection)  with WinXP und Win7 PCs.
    Please contact me too.

    Juri

  • Hello Rebecca,

    I have the same problem:

    Could you please help me to solve it?

  • Valentine,

    Just to make sure, which port is the USB cable plugged into?  The USB cable should be connected to the DEBUG port (the top one), and not the DEVICE port.  The switch should be pushed to the right for DEBUG.

    -Rebecca

  • Sorry for my English.. 

    But thank you for your concern.  I used to do exactly that way :)

  • Valentine,

    I was just making sure you didn't miss that step as this is a common mistake for new LaunchPad users.  I'll contact you offline for further instructions.

    -Rebecca

  • I've bricked my launchpad,

    I have the same problem to see only the "Stellaris Firmware Upgrade" in my device manager.

    But I've made a huge mistake, I've used the LM FLash Programmer software and downloaded the C:\StellarisWare\boards\ek-lm4f120xl\blinky\rvmdk\blinky.bin to the target, that I thought "was" my ICDI.

    There is any way to recover my launchpad, or i will need a JTAG now?

    Thanks,
    Rogério

  • the last message was from a different account (not my), this computer was already logged, please answer by these post. Sorry

    I've bricked my launchpad,

    I have the same problem to see only the "Stellaris Firmware Upgrade" in my device manager.

    But I've made a huge mistake, I've used the LM FLash Programmer software and downloaded the C:\StellarisWare\boards\ek-lm4f120xl\blinky\rvmdk\blinky.bin to the target, that I thought "was" my ICDI.

    There is any way to recover my launchpad, or i will need a JTAG now?

    Thanks,
    Rogério

  • Rogério,

    Is it alright if I contact you offline for more questions about your board?

    -Rebecca

  • I have had a similar "Board not found" problem.  When plugging in my first LaunchPad board, there was ZERO recognition of it, no attempt to find drivers, nothing.  Thinking this was likely bad hardware of some sort (USB cable vs LaunchPad) I ordered a second LaunchPad with included USB cable, and a third USB cable.  The second board was recognized by the PC, and drivers were installed.  This driver installation was odd, though, and although 3 drivers were installed there is still a yellow question mark next to the "Stellaris ICDI Debug Port".  See attached. 

    Does this Debug Port need to be installed?  If so, why wasn't it detected and installed automatically?  

    And lastly, I suspect there is a hardware problem with the first LaunchPad.  All three cables work with the second LaunchPad, to the extent the LaunchPad can be seen by Windows.  But none of the cables work with the first LaunchPad.  So it seems to me the first LaunchPad is defective.  

    Suggestions for the ICDI Debug Port?  Suggestions for the defective LaunchPad?

  • Well, the LaunchPad isn't the only thing that's weird.  The paste function in this blog doesn't work either.  So I was unable to attach a tiff showing the Device Manager window in Windows.  

  • If you do have the issue that Rebecca helped me solve, it's will not be a hardware issue, it will be a firmware issue. With your first board, what happens if you remove the jumper and connect it via the debug USB port? Does it try to install a driver then? (This will not be the drivers you need, but a firmware flashing driver.)

    The second board, I would check your COM port assignment. It kind of sounds like there might be a conflict? For me, as soon as my firmware was updated, it just "worked".

    Rebecca is really helpful and through. If she can help you solve the issue with a firmware reflash, she will do a brilliant job of walking you through the process.

  • Rebecca,

    OK I'm waiting your contact!

    Thanks,

    Rogério

  • James,

    Were you able to try what Matt has suggested?  Regarding your first board, does anything show up in the device manager when the Launchpad is plugged into the PC?  What about after you remove the VDD jumper?

    -Rebecca

  • Rebecca,

    Thanks for your note.  The second board is working as expected.   Regarding the first board, nothing shows up in the device manager when the Launchpad is plugged into the PC, with or without the VDD jumper in place.

    James

  • James,

    How do you have the LaunchPad connected?  Ensure that the switch is pushed to the right to the Debug position and connect the LaunchPad through the Debug USB port to the PC using a USB cable.  Does the green power LED turn on when plugged in?  Can you see the RGB quickstart application running through the different light cycles?  And just to make sure, in the Windows Device Manager, there are no Stellaris or unknown devices under Ports, Stellaris In-Circuit Debug Interface, Stellaris Device Firmware Upgrade, or Other Devices?

    -Rebecca

  • Thanks for your reply. 

    The LaunchPad is connected properly via the debug port, and the switch correct. The power light is on and the test program runs correctly.  In Device Manager, there is no indication of the device in Ports or Other. 

    Is the LaunchPad broken?

  • James,

    If nothing shows up in the device manager when the device is plugged in through the Debug USB port, there might be something wrong with the ICDI chip itself or the circuit around the ICDI (power, crystal, etc.).  Do you have access to an oscilloscope?  Can you check to see if Y5 is oscillates?  Page 22 of the User Manual may be helpful.

    Can you please provide a picture of the bottom of your LaunchPad (specifically if there are any white stickers present)?

    -Rebecca

  • Rebecca,

    I have an oscilloscope, and was able to test Y5.  There was a sine wave with a period of about 62 nSec.  I also took a picture of the back, but I'm having trouble with the paste function of your website.  So for reference, the white sticker on the back indicates 121100741E and there is a second sticker that indicates "Test Pass".

    What next?

    Jim

  • James,

    Can I contact you offline?  If you don't see any devices pop up in the Windows Device Manager when connected through the Debug USB port, there might be something wrong with your LaunchPad's ICDI device.

    -Rebecca

  • Yes, offline is fine.  Do you need my email address?

    James

  • hi everyone,i have tried to connect the stellaris launch pad to my lap top but i had problems with it can anyone help me?

  • Tas Tas,

    How is your LaunchPad hooked up to your PC?  Ensure you are connected to the DEBUG port on the top of the LaunchPad and that the switch is switched to the right.  What are you seeing?  Can you send a screenshot of your Device Manager?

    -Rebecca

  • Hi,

    I'm wondering if someone can please help me. My stellaris Launchpad(s) is(are) no longer connecting properly in my pc device manager. They were working fine in the past and I am tearing my hair out trying to get them to reconnect.

    I have absolutely no idea why it changed.

    I have tried reinstalling the drivers from the link provided to no avail. Windows doesn't seem to detect the device at all as I had to manually add those devices.

    When I plug the stellaris in, it executes my previously uploaded code, but it is impossible to communicate with.

    I am running windows 7 64 bit.

    When I click on properties it says "This device cannot start. (Code 10)"

    Here is a screenshot.

    Any help greatly appreciated. I REALLY don't want to reinstall windows.

    Thanks

    Dave

     

     

  • Dave,

    It looks like your drivers are not installed correctly or have gotten corrupted.  Error 10 is usually caused by outdated or corrupted drivers.  Try deleting the Stellaris ICDI drivers, download them again from the site (http://www.ti.com/tool/stellaris_icdi_drivers), and then reinstall them using the Windows 7 instructions in the Stellaris Driver Installation Guide.  A restart of your computer may also help get rid of the error.

    -Rebecca

  • Hi Rebecca,

    Thanks for response, but still no go. I uninstalled the stellaris items in device manager and ticked the "delete the driver software for this device" box.

    I then proceeded to reinstall via the instructions in the pdf http://www.ti.com/lit/ml/spmu287a/spmu287a.pdf but get stuck at step 1.2 as the pc does not detect the icdi device as it should. Its like it hasn't been plugged in at all but it is powered up. I have tried 3 different usb ports on the computer but no go. I know the ports work as they work fine with my arduino and my MSP430G2553 Launchpad.

    Basically my PC wont detect the stellaris in any form in the first place  for me to then update the driver.

     

    All I can do is manually add the device which is what I had done earlier as an attempted fix, but its like it still doesn't see it.

     

    Anything else I can try?

     

    Thanks

     

    Dave

    P.S. I also have a laptop with 32 bit windows 7 Service pack 1 on it instead of 64 bit which is n my main pc. It wont detect the stellaris's either.

  • Hi Rebecca,

    I am so sorry for wasting your time. It turned out to be a dud usb cable.

    I read another users solution here http://e2e.ti.com/support/microcontrollers/tiva_arm/f/908/t/244496.aspx

    I cracked open the other stellaris usb cable and it detected it first go. I've updated the drivers and am back in business.

    Thank you very much for your help. I assumed cable was ok as it was powering the stellaris, but mine too must have been a data line problem.

     

    Thanks again.

    Dave ( I cant believe I didn't check that earlier)

  • I have same problem with EK-LM4F120XL board. When i plugged in my Stellaris Launchpad to my PC (Windows 8 x64) i got next device in Device Manager:

    Im using drivers from spmc016.zip ("stellaris_icdi_drivers").

    I cannot now found devie in CCS and even LM Flash Programmer says:

    Please help me to start my board.

  • SimpleSoft,

    Sorry for the delayed response.  How do you have the LaunchPad connected to the PC?  Verify that it is connected through the DEBUG USB port and not the DEVICE USB port.  If it is connected to the DEBUG USB port, then it does look like you have the same issue.  If this is the case, do you mind if I contact you offline for further information?

    On a similar note, what is connected to your PC at the time of that LM Flash Programmer error message?  I tried to reproduce it here and was unable to do so.

    -Rebecca

  • Yes, we are using DEBUG USB. ALso you can contactact we me.

  • i'm having similar problems like yours except that i'm using windows 7. plz can you help me out if u found the solution,

  • did u found any solution? i'm facing the same problem. Unable to find any ICDI devices.

  • i found a solution :) 

    i changed my usb port  to esata port and it works fine now