This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TMDSDOCK28335: connect issue of worked with MATLAB through Simulink in external mode

Part Number: TMDSDOCK28335

Hi teams,

    Good day!

   My customer encounter difficulty when use TMDSDOCK28335 worked with MATLAB through Simulink in external mode. He have refer to the thread 569793 , but it can not resolve his issue, there are the detailed information:

   " I have C2000 TMDSDOCK28335 experimental kit . I have MATLAB 2018a installed on my laptop and I am trying to run the experimental kit through Simulink in external mode.I have connected it through USB.

   Firstly I am trying to run a simple model using pulse generator and digital output block for TMS2833x. But I am getting the following error on running:

  Error occurred while executing External Mode MEX-file 'ext_comm': Failed to connect to the target. A time-out occurred while waiting for the connection response from the target. Possible reasons for the time-out:

 a) The target is not switched on.

  b) The target is not connected to your host machine.

  c) The application for the model is not running on the target. You might have clicked the Stop button. If the Run button is not dimmed, click it. Otherwise, click the Build button, which downloads and runs your application on the target.
Component:Simulink | Category:Block diagram error
Unable to connect to the 'TI Delfino F2833x' target for 'first'.
Component:Simulink | Category:Model error

This happens at the very last of the run process after build and compile is completed and code generation is successful.  But connection to hardware fails giving the above mentioned error message.
As a solution I have tried the following methods which I came to learn on various forums including MATLAB Answers and TI support:
i) Switched off SW1 on the control card whereas all the four switches in SW2 are ON by default.
ii) Closed J9
iii) Verified and reinstalled the drivers for XDS100 Class USB Serial Port (COM6) at Device Manager -> Ports (COM & LPT)
iv) Checked "Load VCP" in both XDS100 Class auxilliary  and debug ports.
v) In configuration parameters -> Hardware Implementation, the oscillator clock frequency is set to 10 MHz from 30 MHz and CPU clock frequency is 150 MHz.
vi) The baud rate wherever mentioned including SCI_A is set to 9600 bits/sec.
vii) Rx and Tx are at pins 28 and 29 respectively
viii) In external mode, communication interface is serial and the serial port is COM6 same as that noted for XDS100 in Device Manager -> Ports (COM & LPT). 

Could you kindly help to check the information upside and give us some suggestion how to resolve the connect issue.

Best Regards
Miao Bai