Update from 8 to CCS10 breaks code

Other Parts Discussed in Thread: MSP430F5438A, MSP430FR5962

AI have several existing projects for MSP430. After updating CCS from 8 to 10 there are wired issues:

1. Compiling code

#include <msp430.h>
#include <vector>

void
test()
{
}

Building file: "../test.cpp"
Invoking: MSP430 Compiler
"ccs1020/ccs/tools/compiler/ti-cgt-msp430_20.2.2.LTS/bin/cl430" -vmspx --data_model=restricted --use_hw_mpy=F5 --include_path="ccs1020/ccs/ccs_base/msp430/include"  --include_path="ccs1020/ccs/tools/compiler/ti-cgt-msp430_20.2.2.LTS/include" --include_path="ccs1020/ccs/tools/compiler/ti-cgt-msp430_20.2.2.LTS/include/libcxx" --define=__MSP430F5438A__ --define=_DEBUG --define=DEBUG -g --c99 --printf_support=nofloat --diag_warning=225 --diag_wrap=off --display_error_number --silicon_errata=CPU21 --silicon_errata=CPU22 --silicon_errata=CPU23 --silicon_errata=CPU40 --asm_listing --c_src_interlist --section_sizes=on --preproc_with_compile --preproc_dependency="test.d_raw"  "../test.cpp"
FILE: test.obj
CODE  size (bytes): 2
 
"ccs1020/ccs/tools/compiler/ti-cgt-msp430_20.2.2.LTS/include/_atomic.h", line 108: warning #48-D: incompatible redefinition of macro "_disable_interrupts" (declared at line 129 of "ccs1020/ccs/tools/compiler/ti-cgt-msp430_20.2.2.LTS/include/intrinsics.h")
Finished building: "../test.cpp"

2. One application which runs perfectly on CCS8 does not function on CCS10 because the optimization needs to be reduced to balanced 3 instead of speed 5. Reason not found yet.

3. One application using I2C does not any longer produce interrupts after sendind a byte on the interface. Just using the driverlib (2.91.13.1) provided by TI (no optimization at all)

4. Changing from CCS8 to CCS10 requires to change the targetConfigs for debugging as someone decided to change from lower case to upper case filenames

                <instance XML_version="1.2" desc="MSP430FR5962" href="devices/msp430fr5962.xml" id="MSP430FR5962" xml="msp430fr5962.xml" xmlpath="devices"/>

                <instance XML_version="1.2" desc="MSP430FR5962" href="devices/MSP430FR5962.xml" id="MSP430FR5962" xml="MSP430FR5962.xml" xmlpath="devices"/>

So is there anything which needs to be done on tool update which I didn't see and any hint, how to track down this runtime errors

Best regards

Christian