This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

CC2540 USB dongle driver installation problem

Other Parts Discussed in Thread: CC2540, CC2541, CC1201, CC2541DK-MINI


I am trying to install driver for my CC2540 usb dongle in my Windows 8 OS pc.

but it is showing error message.

i am selecting driver path "C:\Texas Instruments\BLE-CC254x-1.3\Accessories\Drivers" 

as shown in below image error is coming 

please suggest how do i install driver for this dongle 

  • Apparently, there has been a change in Windows 8 related to signing of drivers. Win 8 now enforces that all drivers (related .inf files) have a digital signature. Without the signature, the driver will not be installed. On win 7, you could ignore the error and install anyway, but not so for Win 8. The driver (or really, the .inf file) for the dongle has not been certified by TI yet.

    However, as shown above, there are methods you can use to turn this enforcement off. Here's some more info:

  • Hi TI Employee,

     Your suggested method does not work. As noted by Bruce in this post ( )

    This is a serious issue. How quickly this can be resolved ?



  • Hi TI Employee,

    Just wanted to let you know that this is a non issue for me now. I tried it myself and was able to install it successfully without any issues.   


  • Please try the attached signed driver.
  • Hi,

    just for information:

    I tried the above attached signed drivers and it worked well on WINDOWS 8/64bit.


    Norbert Witt

  • Thanks for this driver that works with windows 8! Its weird because the newest TI BLE software stack (v1.3.2) for CC2540 mentions this in its readme:

    - A new Windows USB CDC driver has been included in the installer. This new
    driver is signed and is functional on Windows 8 systems.

    However that clearly isn't the case, at least for me. I get the signature problem that everyone else is having on Windows 8 machines. This driver you provided however works fine! It would probably help a lot of people out if you guys updated that package or at least made a note on the TI BLE stack download page. Thanks again.

  • Thanks for noticing! The BLE stack installer is actually missing the .cat file (it only includes the new .inf file). So for now, please continue to use the one I posted in this thread, and we will update the installer.

  • Maybe I'm just doing something wrong but after downloading and extracting the driver folder I can't seem to get it to work. I've tried directing the device manager to the extracted folder only to have it tell me that it can't find any driver files, then I tried picking from the list of drivers on my computer as shown in the pictures below only to have download errors. Can anyone fill me in as to what I'm doing wrong?

  • Hi!Please make sure the software on dongle is correct!if not ,the driver can't be valid!

  • Hi,

    I have installed the RFStudio 7 which includes all necessary drivers as suggested on some of the post. I have noticed one thing when adding device manually. I can see the Texas Instrument in standard Serial port devices.But no device like TI CC45XXXX CDC?

    I have Windows 7 64 bit and mini Development kit

    Here is the list for same.

    MSP Application UART1

    MSP Application UART2

    MSP Debug Interface

    MSP430 Application UART

    MSP-EXP430F5438 USB Serial port







    TUSB3410 Device


    So anyone please help to resolve the same.



  • I have noticed one more thing with RFStudio 7 that when I connect the SensorTag on serial port RFStudio detects the CC2541 but unable to detect the usb dongle when connected on CC debugger's serial port. 

  • Sandip,

    The required CDC driver files are located in C:\Program Files (x86)\Texas Instruments\SmartRF Tools\drivers\vcp (ccxxxx_usb_cdc.*).

    Not sure if I understand your second question. Do you connect the CC debugger to the CC2540 USB dongle, but can't see the device in SmartRF Studio? Have you applied any power to the dongle (it needs to get power from a USB port)?

  • Hello,

    Thanks for your response.

    I have found solution. Tried last answer by on and it works.


  • Hi,

    I have a problem related to the installation too:

    It seems i succeed to install driver as it display the dongle properly in the device manager, however it seems not COM port is allocated to it

    result: when i go to BLE device monitor of course it doesn't find the dongle on com1 and doesn't propose me any other port..

  • Here is the 9 steps described on

    1. Install newest version of SmartRF studio before plugging in the dongle (this includes the newest CDC drivers from TI)
    2. Connect the CC Debugger through the pin row on the dongle
    3. Power on the dongle through an USB port
    4. Reset the CC Debugger, ensure you get a green light on the debugger
    5. Delete any remaining TI devices from previous installs in Device Manager / Ports
    6. Do an erase/program/verify with  CC2540_USBdongle_HostTestRelease_All.hex 
    7. If you verify against the hex in the Flash programmer you will get an error, most likely due to the on-chip bootloader which is not a part of the HostTestRelease image.
    8. When "new hardware" shows up, select "No" to search in Windows Update, then select to install the driver automatically
    9. The driver that will be installed is TI CC2540 Low-Power RF to USB CDC Serial Port (COMXX) from c:\windows\system32\DRIVERS\usbser.sys

  • I am going to try this again

  • Just to clarify. The CC2540 USB dongle comes in three variants, depending on which kit you get it from. The variant is marked on the label on the back of the dongle.

    The "DK" variant is programmed with the packet sniffer firmware (enumerates as a "Cebal controlled device").

    "MINIDK" is programmed with the "Host Test" firmware from the BLE stack bundle to operate with BTool (enumerates as a COM port).

    "ARC" is programmed with HID firmware to work together with the CC2541 Advanced Remote Control (enumerates as a HID device).

    As is already mentioned in this thread, you need to program the dongle with the file "CC2540_USBdongle_HostTestRelease_All.hex" in order to use it with BTool.

  • Ok, now i understand better the why :)

    in my case the CC2540 appear as Cebal, so i guess it is normal it doesn"'t appear in PORT COM ?

    I checked the TI packet sniffer by using the sensor tag i also have and it seems to work now (i can see the sniffing).

    So from what i undertsand i will have to change the firmware inside the dongle to be able to use it with other tool of ti

    However I have another difficulty i have is when i plug the dongle to the CC debugger and i press the button, the light doesn't turn green. so i can not upload the firmware..

    Any reason why ?

  • Are you powering the dongle over USB? The debugger does not (by default) supply any power to the dongle.

  • i got the usb dongle powered via usb to my computer one side and i plug the jtag on the other side

    i tried with the sensor tag too (with and without coin cell on it) and it didn't get anything.

    By the way, Ti employee, thank you very much for your fast reply , this is very enjoyable, reason i chose Ti for our first dev kit: seems the support is excellent

  • Do you have a picture of your setup? This should normally work without any problems.

    Have you checked the CC Debugger cable? In a very few cases, we've seen that the cable might be broken or that there's something wrong with the small adapter board between the debugger and the small cable.

  • I will try to take picture as soon as my phone is recharged.

    Currently the setting is as follow:

    Usb cable in computer go to the usb of the cc debugger, the jtag cable go from the the jtag port debugger to the adapter, the adapter is plugged on the dongle

    firmware inside the cc debugger is firmware 0042

    what is terrible is i saw it passed to green one time and unconnected it to make sure i could reproduce it again, and since then , no green anymore on any of all the deive i have : keyfob, dongle, sensor tag

    I would not be amazed this is a cable issue coming from the jtag cable... as i just see the led passed to green  again (and then rf studio indicate CC1201 instead of nochip) and then when i pressed again it turn to red, very strange..

  • i found out the problem was coming from the JTAG cable which was defective.

    Bought a new one and it works fine now, the debugger can turn green perfectly and the chip is detected properly by the studio

    Thanks for your help by the way :)

  • Hi Christopher,

                                I have the same problem. Did you find the right solution?

    Does your BLE device monitor find the dongle on a COM port?

    Thank you

  • Hi Giuseppe,

    Have you verified that you have the correct firmware programmed on the USB dongle?

  • Yes the firmware was different. Thus I bought the cc2541dk-mini kit. The USB dongle is a virtual COM port and works with BTool but don't work with Bluetooth Device Monitor for monitoring SensorTag application. Is there any other configuration of US dongle? Thank you.
  • There was an issue with an earlier version of Device Monitor (v1.4). Please make sure you use the latest and greatest version (version 1.5).

  • Hi,

    I am having the same issue. I have installed the latest version of BLE Device Monitor. See, post below. I would assume that by now the BLE USB Dongle will just be plugged in at Windows 10 PC and work without problems with BLE Device Monitor.

    - kel
  • Hi kel, I have tried to help you on