This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TIDM-NFC-EZ430-MODULE: Can the TIDM-NFC-EZ430-MODULE reference design read RF37S114 tags?

Part Number: TIDM-NFC-EZ430-MODULE
Other Parts Discussed in Thread: RF37S114

We have a design that's based on the TIDM-NFC-EZ430-MODULE (NFC EZ430 reference design). It reads ISO 15693 tags from smartrac without any issues. I'm trying to use it to detect and read the UID from a RF37S114 but not having any luck. 

Is ti possible to use this reference design for this transponder, or do I need to make some hardware and firmware modifications? 



  • Hello Michael,

    At what read range are you trying to do this? I am able to read an RF37S114 with that module, but at reduced read range.
  • Thanks for the quick reply.

    I'm laying the tag right on the NFC-EZ430 PCB antenna. I tried moving it just above the board (a few mm) as well.

    I'm using the software examples (unmodified) provided with the reference design in case that makes a difference.

  • Hello Michael,

    Did some more testing on my end, unfortunately I am not able to get the UART communication to come up on my PC so I am flying blind as far as the UID goes. For the default code base, I get the red light to come on when presenting the RF37S114 tag, do you see that behavior as well but get no UID?

    I had another firmware example for the board as well so I tried that out and on that one it looks like the performance is poor, so it could be that the antenna is too large for 3V operation to reliably read the tag.
  • Hi Ralph,

    I was eventually able to get the red light to come on when I had a piece of paper between the tag and the antenna, and by placing the tag in one exact spot. So now that I know that it's possible I might redesign the antenna to optimize for this tag. Thanks for looking into this! 

    As an aside, I have trouble talking over the virtual serial port via the MSP430 dev board that's connected to the NFC-EZ430 too. The TTL UART coming off the NFC-EZ430 works reliably, it's just when I'm trying to debug with the MSP430 attached I don't get any VCP serial data. I finally just chalked it up to a windows/USB3/driver thing.