This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.


Other Parts Discussed in Thread: CC1101, CC110L, CC115L

Can SmartRF Studio 7 be run under Windows 10, I have been using Windows XP successfully...

  • Hi,

    SmartRF Studio 7 runs on 32 and 64-bit versions of Microsoft® Windows 7, 8 and 10.


  • Hi Zack

    I loaded SmartRF Studio 7 on my PC (running Windows 10), and it loaded until it came to loading the USB driver...

    It gave me a message "unable to load Driver xx".... I pressed continue, and it loaded more and again issued the

    same message. The software fails to "recognise" the connected module... it seems to be just a driver issue ??

    Many thanks for your help...


  • Hi Frank,

    Was the error message exactly "unable to load Driver xx" or did it give more specific information on which driver is causing a problem?

  • Hi Zack,

    First, the software version I have is "SmartRF_ Studio_7-1.10.3".... The exact message I get is "Not able to install driver for C:\Program Files (x86)\Texas Instruments\SmartRF Tools\drivers\vcp\srf05eb_uart.inf" I have now tried to load on my other half's laptop (running 10)... and I got exactly the same result.

    Hope this makes some sense to you... 



  • Any reason you are trying to install a very old version? Try to install the newest from

  • Hi Zack,

    I installed what I assume is the latest version (6.13.1)... This loaded without error, I selected for the CC1101 (the CC110L is the chip in the TrxEB),

    connected the TrxEB module... USB ack'd OK but nothing appeared "connected" (as before). I dug out an old laptop running Windows 7... again the

    "new" version loaded without error, but the same result... no connect. The TrxEB's I have are rev. 1.7, and these appear to be working OK... they will

    talk to each other in "Easy_link mode. Could these modules need to be updated ?? 

  • Hi TER...

    Sorry... I thought it was Zack back to me... Could it be the "old" driver interfering with the "new" one ?? How do I remove the driver in Windows 10 ??

    (the "uninstall" does not seem to remove the driver, but I could be wrong about that ??



  • Hi Frank,

    Just to avoid confusing the SmartRF Studio version and the driver error message, it's best to check your SmartRF Studio installation first:

    If you are running an EB board with a CC110L then you will need to use SmartRF Studio 7 (the latest version on as of posting this is 2.24.0); if I understand your post correctly, I think you have accidentally installed SmartRF Studio 6 (v6.13.1) instead.

    For reference, there is a list of devices supported by SmartRF Studio 6 and 7 on the overview of the page above.

    Please can you confirm (or not) that v2.24.0 of SmartRF Studio 7 successfully installs (ideally from a "clean" install) and if your CC110L device is recognised? The CC110L is selectable in the GUI, separate to the CC1101.

  • Hi Zack...

    I did reckon there was something wrong with the "6"... I installed v2.24.0 of SmartRF Studio 7 successfully, I uninstalled all the

    previous attempts to try and make it a "clean" installation. The problem is still there..!!! no response (other than the #10 ack) when

    I plug in the EB... (I tried both of them)...  Any other way I can check the Installation... ?? 

  • Hi Zack,

    Just to let you know... I installed the latest version on a couple of laptops... one running "7" and the other running "10".... both

    installed without error, and both failed to recognise the EB... I noticed on the "7" version that the "refresh list" Icon (bottom right

    of the startup menu page) responded briefly but did not register the EB... so the software (on the "7" in any case) does "see"

    the device connected to the USB ?? yet another Microsoft Triumph no doubt... I'll see if I can get my hands on a "virgin" "10"

    PC... I have a feeling that all three machines here have had TI S/W in and out... so may not be "clean"...



  • Hi Zack,

    I have now installed this software on a laptop PC that  was "clean" (never had this software installed), with the same result.

    The EB is not recognised, Is it possible that the EB's are the trouble ??... I don't have any other module(s) to try, and I don't think

    there are any replacements in stock ??.



  • Hi Frank,

    Apologies if I am repeating things but just to clarify:

    • You are using a CC110LEM (868 - 915 MHz?) using a TrxEB v1.7
    • You are now using SmartRF Studio 7 v2.24.0
    • When you plug an EB into the TrxEB board, it seems that the device is "seen" but is not visible in SmartRF Studio?

    If so, I will first see if I can find some of the same EMs and TrxEB board revision and see if the issue is repeatable on my end. 

  • First, please can you check that the "USB mode" hadware switches on your TrxEB are set to "SmartRF" and "Enable" (the top setting in the attached table)? You'll have to turn the power on your TrxEB board off/on again once the CC110LEM is inserted if you do need to change this for the device to be recognised.

    Additionally, if this does not solve the issue please go through the TrxEB User Guide: first as it contains information on installation. Section 4.2 has information on driver installation(s).

  • Hi Zack,

    Yes.... all OK except that the EM plug-in modules in use are 434 Mhz. The TrxEB's were last used on a PC

    running Windows XP... with no problems. The EM PCB's are marked CC115L and CC110L V1.0. I do have 868 Mhz modules,

    but can't see that they would be the problem. The EB's run 100% on all "manual" functions... ???  The venerable XP PC was

    only dumped a few weeks ago..!!!



  • Hi Frank,

    I have just tried with a CC110L v1.0 (also marked with CC115L) 434 MHz module too using a TrxEB v1.7 and SmartRF Studio 7 v2.24.0 on a Windows 10 PC, it was recognised successfully.

    To add to the User Guide above, there is also an App Note with information on installing the drivers (SWRA366):

    After checking the TrxEB switch settings, please go through the App Note and User Guide linked above and let me know if that solves the issue.

  • Hi Zack,

    OK... enough stuff to keep me busy... I'll go through it and report back...

    Cheers and many thanks,