The TI E2E™ design support forums will undergo maintenance from Sept. 28 to Oct. 2. If you need design support during this time, contact your TI representative or open a new support request with our customer support center.

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

LAUNCHXL-CC1310: Why does the sleep(x) function call not return on CC1310 when using TI-RTOS and CCS compiler?

Part Number: LAUNCHXL-CC1310
Other Parts Discussed in Thread: CC1310

I have a rookie question and decided to take my beating and potentially get an answer vs. continuing to beat my head against the wall wondering why. 

  • I am using Code Composer Studio version 12.
  • I have a CC130 Launchpad as my device and I am loading the Resource Explorer example under: SimpleLink CC13x0 SDK - 4.20.02.07 ->Examples ->Development Tools ->CC1310 Launchpad ->Demos -> portable -> TI-RTOS -> CCS Compiler -> portable 
  • I made a simpler modification to mainrtos.c (two lines of code):

/*
 *  ======== main_tirtos.c ========
 */
#include <stdint.h>

#include <unistd.h>

/* POSIX Header files */
#include <pthread.h>

.

.

/*
 *  ======== main ========
 */
int main(void)
{

    pthread_t           thread;
    pthread_attr_t      attrs;
    struct sched_param  priParam;
    int                 retc;

    /* Call driver init functions */
    Board_init();

.

.
    // --- put thread to sleep for a short time
    sleep(1);

    /* Initialize the GPIO since multiple threads are using it */
    GPIO_init();

.

.

}

Can anyone shed light on this for me?

Thank you...

JRW