This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TIDC-01002: CCS/LAUNCHXL-CC1352R1: TI-RTOS Sensor To Cloud Industrial IoT Gateway Demo

Part Number: TIDC-01002
Other Parts Discussed in Thread: TIDA-01002, CC3220SF


Stumbled on another step of the TIDA-01002 demo: "Using the SimpleLink Starter Pro App".  All steps work as described until step 13...

   13)  Click the open button on the dashboard to allow sensors to join the network.

I go to my IBM Cloud Foundry App URL but there is no "open" button. When I refresh the page the open button is displayed for less than 1 second then disappears. I think the co-processor is not talking to the CC3220SF.  I've run out of ideas... help!

Hardware on hand:

- 2x CC1352R1 LauchXL pcb rev B

- 1x CC1312R1 LaunchXL pcb rev D

- 1x CC3220SF LaunchXL.rev A

 Have tried different combinations of above PCBs, loading prebulit files from TIDA01002 git and also compiling from source and tweaking UART pin assignments. No luck.

Below is typical terminal output from CC3220SF:

[Cloud GET Handler] Payload: {"ipAddress": "", "wifiConnection": 1, "mqttConnection": 1}

[Link local task] Metadata Sent, len = 48
[Link local task] Data Sent, len = 71
[NWK GET Handler] Callback Called:
[NWK GET Handler] Metadata Sent; , len = 48
[NWK GET Handler] Data Sent: [Dev GET Handler] Callback Called:
[Dev GET Handler] Dev Data: [Link local task] Metadata Sent, len = 48
[Link local task] Data Sent, len = 0

[Cloud GET Handler] Callback Called:

[Cloud GET Handler] Payload: {"ipAddress": "", "wifiConnection": 1, "mqttConnection": 1}

[Link local task] Metadata Sent, len = 48
[Link local task] Data Sent, len = 71
C: Net 1, Sending Ping request [639]
C: FH-B1 0xc0 to net 1, Sent (2 Bytes) [@ 639]
C: Rcvd msg Fix-Hdr (Byte1) 0xd0 from net 1 [@ 640]
C: Msg w/ ID 0x0000, processing status: Good

  • Hello LS_SPP,

    Are you using the Coprocessor images supplied on the git repo? or from the latest SDK, I believe that the latest sdk has not been tested with this demo.
    Try pressing the reset switch on the coprocessor board and see if you see anything o the terminal.

  • Hi AB,

    Thanks for your quick reply!

    I've tried using the Coprocessor images supplied on the git repo (git:// When that didn't work I thought I would try debugging and imported the gateway and coprocessor projects into CCS.

    I found the gateway projects would compile without errors only if I used an old SDK: "15_4_Stack_Gtway_IBM_CC3220SF_LAUNCHXL_tirtos_CCS" required SimpleLink CC32XX SDK to compile without errors. I tried to run this with "coprocessor_cc1352r1ilp" using SimpleLink CC13X2 SDK

    When I press the reset button on the coprocessor nothing happens. I have the coprocessor stacked on the CC3220 PCB. The CC3220 PCB has all jumpers in place as it came out of the box. The coprocessor has reset and external power supply jumpers only. The coprocessor  PCB has 5V and 3V3. The reset lines toggle with button press, no LEDs are operating and I can't see data on TX/RX pins with a scope even after a reset.

    I've tried tweaking CC1352R1_LAUNCHXL.h to change UART0_RX  and UART0_TX  to pins 9 & 11

    I guess I'm doing something fundamentally wrong ie  incorrect files / SDKs. 

  • Hello LS_SPP,

    You are not doing anything wrong. The version of sensor to cloud that we have available on the web was devolped on SDK v1.50.

    If you wish to modify this example you will need to download this SDK from our archives in

    But, I would recommend you stick to the images supplied on the git repo, rather than the new ones, since this demo was tested with the supplied images. Do not change any of the pin definitions and keep as is, and try reseting the coprocessor after everything has booted up and see.

    I have a demo currently working here in my desk with the supplied images with no modifications on lauchpads.

  • Hi AB,

    Thanks for your efforts in setting up a demo and confirming it all works. I've also tried again from scratch but had no luck. I think I am facing a hardware issue on the CC3220 launchpad. I will order a replacement and try again.