This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

LAUNCHXL-CC3235S: SimpleLink SDK 5.30 Upgrade Errors

Part Number: LAUNCHXL-CC3235S
Other Parts Discussed in Thread: CC3235S, SYSCONFIG


I am trying to encorporate new 5.30 SDK drivers into an existing project (the AWS provisioning project: " subscribe_publish_sample ").

I am using CC3235S eval/dev board, Latest AWS plugin and latest SL SDK 5.30.

I am getting 33 unresolved symbols remain errors which makes me think I am not providing the definitions for these driver objects.
The project is dependednt on my RTOS project, tirtos_builds_cc32xx_release_ccs.

I have confirmed in the "Products" section of project properties for both projects that the 5.30 SDK is being used as well as latest XDC tool and sysconfig.

Would someone mind lending a hand as to how I can define these symbols? It seems that the library path could be wrong or missing.

Thank you.

  • It seems that the "dpl_cc32xx.a" library is missing (you can find it under <SDK_INSTALL_DIR>/kernel/tirtos/packages/ti/dpl/lib/...).

    You should add it to the project (project properties -> Bulid -> Arm Linker -> File Search Path).

    The latest SDKs use syscfg to link the TIRTOS libraries automatically, so you either update the syscfg file or add the library manually.

  • Thank you Kobi.

    I was not able to update the sysconfig file because it was throwing an error related to tirtos7.

    I was able to include it manually by going to project properties-> CCS Build -> ARM Linker-> File Search Path

  • ok. thanks fot the update.

  • I ended up needing to do this for another project (the shadow example project), and this fix did not work. What is also strange is that I ended up reloading the aws_provisioning project again, so this issue re-occured. The solution did not work for the newly reloaded project either. It only worked that one time, the day you mentioned it. Is there any reason why this fix would work once and never again?

  • There is no reason. If the error relates to those same missing symbols, then adding the library will fix it (maybe you see different "unresolved symbols"?). 

    You can also try to start from a working 5.30 project and add your sources (everything other than syscfg - that you will need to change manually).

    What do you mean by "reloading the aws_provisioning project again"?

  • Thank you. I just meant that I deleted the project and re-added it. That was the only reason why I needed to re-do this fix again. I did everything that was done the first time again, but it never worked. I ended up just reverting back to 5.20. There are too many compatibility issues and compilation errors.

    Thank you for the help.

  • ok, thanks again for the update.

    The difference between 5.20 and 5.30 is not huge (mostly the syscfg issues you are facing).

    I recommend that at least you will use the SP from 5.30 (this doesn't require any software change).

  • I will use the SP from 5.30. I will also try to use 5.30 when I can moving forward. The AWS projects are a little complex, so maybe it's just the AWS stuff that's rough. Thanks for the help.