This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

CC2530-CC2591EM-RD: Unable to control end device

Part Number: CC2530-CC2591EM-RD
Other Parts Discussed in Thread: CC2530, Z-STACK, CC2531

Dear TI,

We have used the CC2530+2591 Zigbee modules and used the standard 1.2 version firmware for Coordinator, and paired 20 devices (lighting modules) to one coordinator the devices working well for a couple of weeks, suddenly some modules not working from the app, so we tried to reconnect it but it is not reconnecting, we tried to replicate the same scenario in my bench, so we used the C2531 dongle and paired 1 lighting module with that, initially we could able to control the light using AF_DATA_REQUEST, after one or more commands the module stops responding, later we power recycled the module then it works for the first time, again stops working again power restart makes work for 1 time. This is happening in the site also. What could be the cause of this problem, earlier we controlled several times it was ok but now the problem is there. Please help us to resolve this.