dsp server compilation problem

Hi guys,

I am getting compilation error while building the dsp server.

 will link with ti.sdo.ce.examples.codecs.Mpeg4_Lnt_decoder:lib/Mpeg4_Lnt_decoder.a64P
    will link with ti.sdo.ce.lntvideo:lib/release/vidmpeg4decoder.a64P
    will link with ti.sdo.ce.bioslog:lib/release/bioslog.a64P
    will link with ti.sdo.ce:lib/release/ce.a64P
    will link with ti.sdo.ce.alg:lib/release/Algorithm_BIOS.a64P
    will link with ti.sdo.ce.ipc.bios:lib/release/ipc_bios.a64P
    will link with ti.sdo.ce.osal.bios:lib/osal_bios.a64P
    will link with ti.sdo.ce.osal.bios:lib/osal_bios_load.a64P
    will link with ti.bios.utils:lib/utils.a64P
    will link with ti.sdo.fc.acpy3:lib/release/acpy3.a64P
    will link with ti.sdo.fc.memutils:lib/release/memutils.a64P
    will link with ti.sdo.fc.dskt2:lib/release/dskt2.a64P
    will link with ti.sdo.ce.utils.xdm:lib/release/XdmUtils.a64P
    will link with ti.sdo.utils.trace:lib/release/gt.a64P
    will link with ti.sdo.ce.node:lib/release/node.a64P
    will link with ti.sdo.fc.dman3:lib/release/dman3Cfg.a64P
cl64P package/cfg/Mpeg4_Lnt_decoder_x64P.c ...
asm64P package/cfg/Mpeg4_Lnt_decoder_x64Pcfg.s62 ...
cl64P package/cfg/Mpeg4_Lnt_decoder_x64Pcfg_c.c ...
XDCPATH/home/mahesh/dvsdk_2_00_00_22/codec_engine_2_23_01/examples/ti/sdo/ce/examples/servers/Mpeg4_Lnt_decoder/evmDM6446/../../../../../../..;/media/hda2/home/mahesh/dvsdk_2_00_00_22/codec_engine_2_23_01/packages;/media/hda2/home/mahesh/dvsdk_2_00_00_22/xdais_6_23/packages;/media/hda2/home/mahesh/dvsdk_2_00_00_22/dsplink-1_61_03-prebuilt/packages;//home/mahesh/dvsdk_2_00_00_22/linuxutils_2_23_01/packages;/media/hda2/home/mahesh/dvsdk_2_00_00_22/framework_components_2_23_01/packages;/media/hda2/home/mahesh/dvsdk_2_00_00_22/biosutils_1_01_00/packages;/media/hda2/home/mahesh/dvsdk_2_00_00_22/bios_5_33_03/packages" /media/hda2/home/mahesh/dvsdk_2_00_00_22/xdctools_3_10_03/xs xdc.tools.configuro -c /media/hda2/home/mahesh/dvsdk_2_00_00_22/cg6x_6_0_21 -o Mpeg4_Lnt_decoder \
                -t ti.targets.C64P -p ti.platforms.evmDM6446 -b //home/mahesh/dvsdk_2_00_00_22/codec_engine_2_23_01/examples/ti/sdo/ce/examples/servers/Mpeg4_Lnt_decoder/evmDM6446/../../../../../../../config.bld \
                --tcf Mpeg4_Lnt_decoder.cfg
/home/mahesh/dvsdk_2_00_00_22/cg6x_6_0_21/bin/cl6x -@ Mpeg4_Lnt_decoder/compiler.opt -c main.c
/home/mahesh/dvsdk_2_00_00_22/cg6x_6_0_21/bin/lnk6x -o Mpeg4_Lnt_decoder.x64P -c main.obj Mpeg4_Lnt_decoder/linker.cmd

undefined                        first referenced
 symbol                              in file
---------                        ----------------
_ti_sdo_ce__versionString       /home/mahesh/dvsdk_2_00_00_22/codec_engine_2_23_01/packages/ti/sdo/ce/lib/release/ce.a64P
>>   error: symbol referencing errors - 'Mpeg4_Lnt_decoder.x64P' not built
gmake: *** [Mpeg4_Lnt_decoder.x64P] Error 1

with Reagards

Mahesh v kalmeshwar.

 

Best Regards,
Mahesh Kalmeshwar.
http://in.linkedin.com/in/maheshkalmeshwar

5 Replies

  • In reply to Chris Ring:

    Hi Chris,

    I am getting "VISA_create2> Unable to locate alg" Error.

    will you pls clarify that when it is going to fails-means more information about it.

    because codec Engine we are not able to build as per Documentation so how i can  debug the codec Engine.

    constName = Engine_getConstName(engine, tmpName, type);
        if (constName == NULL) {
            GT_1trace(curTrace, GT_6CLASS,
                    "VISA_create2> Unable to locate alg \"%s\".\n", name);
            goto fail;
        }

    Best Regards,
    Mahesh Kalmeshwar.
    http://in.linkedin.com/in/maheshkalmeshwar
  • Hi guys ,

    This Error will give once if your rebuild the Codec engine .

    Sticrtly Documente stated that we should not rebuild the codec Engine.

    To rebuild i need some ti/sdo/ce/libvers.xdt this file is missing.

    and also am not able to rebuild the dsplink.

    /home/mahesh/dvsdk_2_00_00_22/codec_engine_2_23_01/packages/ti/sdo/ce/ipc/dsplink

    its giving the Error linke:

    ti/bios/power/lpm.h no such file

    This file is missing

     

    With Regards.

    Mahesh V Kalmeshwar.

     

    Best Regards,
    Mahesh Kalmeshwar.
    http://in.linkedin.com/in/maheshkalmeshwar
  • In reply to mahesh kalmeshwar:

    hi, mahesh 

    i'm facing with the same issue:

    VISA_create2> Unable to locate alg

    on our target board, i just want to know if you get your problem solved.

    regards, Mike

    Thanks.

  • In reply to zanget:

    Hey  Mike,

    check this tag "MPEG4_Decoder-Intigration --- help full inforamation"  at TI forum.

    it will help full info you will get.

     

    Regard's

    Mahesh

     

     

     

    Best Regards,
    Mahesh Kalmeshwar.
    http://in.linkedin.com/in/maheshkalmeshwar