ez430-RF2500: MSP430 Application UART not reliably available

I've had my RF2500 kit for several weeks now.

In that time I have managed to work my way through the usual set of “new processor” basics: I've managed to convince the IAR Workbench to compile my C code and download it to the target board, and I've been able to successfully flash the LEDs and read the internal temperature sensor. On the other hand, I obviously still have a lot to learn: every time I read the F2274 documentation a new xxxCLK signal seems to have been added (Grin?).

One problem I've encountered has to do with the “MSP430 Application UART”, the MSWinXX driver interface to the F2274's specially-routed UART lines (P3.4, P3.5). Now, I can live with a 9600 Baud speed-invariant interface, but under some as-yet-undetermined circumstances it will completely disappear from Device Manager's list of available devices and only reappear after some serious effort on my part.

First, the equipment: I'm working from a Dell Latitude D630 laptop under MSWinXP SP2 (plus the usual random assortment of Microsoft-supplied “Install these or your system Will Suffer Unspeakable Horrors” patches). I'm using the IAR Embedded Workbench IDE 5.1.1.453.7838 (5.1.1.453), and I have attempted to access the target board's UART via USB under openSuSE Linux, but have had no success to date.

Hardware changes: I've soldered a 2x9 header onto the target board, and trimmed the “dongle” case to permit the modified target board to be plugged in.

Code: I have experienced the problem using the TI-supplied demo_AP.c code/file/project. I see the same problem using Hyperterminal or my own C# COMx port monitor. Unfortunately, I can't seem to reliably reproduce the problem.

It “feels” as if some part of the hardware/software inside the dongle is getting into a state where it won't reset itself after being reconnected. Of course, it could also be that the MSWinXP USB driver code is “holding on” to some characteristic of the hardware even when the dongle is unplugged, and then refusing to re-recognize it because it “knows” the port is busy.

Depending on the phase of the moon, one or more of the following steps seem to necessary to clear the problem:

  1. Unplugging and replugging the dongle.

  2. Cycling power on the laptop.

  3. (Drastic) Removing the target board and plugging in the empty dongle, then hot-plugging the target board into the dongle. I'm not comfortable doing this, and I _certainly_ wouldn't recommend it to anyone who was not already in desperate straits, but it does seem to work as a “last resort” when other options fail.

Has anyone else experienced this?

If so, can you offer any suggestions on how I could fix or work around it?

It's entirely possible that this is what IBM used to call a PUE in its S/360 APARS (Probable User Error), but even knowing that for certain would be useful. I'm also aware that I'm omitting three essential pieces of information in this posting... I just don't know what those are. (Sigh!)

My thanks for any insight anyone can provide on this problem.

 

Frank

 

  • I'm having problems too but mine are worse. The driver used to work fine with the old IAR and CCE v2; I uninstalled them and installed the latest IAR and CCE v3 and since them I can't download anything to the board anymore. I setup the FET Debugger in IAR to no avail. I uninstalled and reinstalled the driver many many times. I tried all the USB ports I have on this machine and nothing. All I get is Failed to initialize in both IAR and CCE.

    At least for you it works most of the time :-(  

    I think I'll give up and use an older computer which still has CCE v2 on it and it works fine.

      

  • In reply to claudiu:

    What kind of error are you seeing? One quick thing to try: make sure you have the latest service pack available for CCE V3. This is a good first step to try and we just released a Service Pack 2: http://focus.ti.com/docs/toolsw/folders/print/msp-cce430.html#Support%20Software

  • In reply to BrandonElliott:

    I did install the SP2 a couple days ago so CCE is up to date. When I try Debug I get:

    Error initializing emulator:
    Could not initialize device interface

    I tried disconnecting the board to make sure at least CCE sees it when connected and in this case the error is below, different than one connected.

    Error initializing emulator:
    No USB FET was found

    I compared the debugger settings in CCE settings to a friend's of mine and they are the same and his works. I found some post in a forum saying the voltage might be a problem when board is powered externally but in my case power comes from USB so it should be fine. Unless somehow all the devices I have on USB make the voltage drop but then nothing would work on USB...

    Thanks for taking a look at my issue.

  • In reply to claudiu:

    Did you ever get this problem resolved?

    I see exactly the same thing, when running the EZ430-2500 on my laptop, using CCE3 SP2. 

    However, when I run on my desktop (both systems use Vista, btw) everything works fine.  This is using the same EZ430 USB unit, and the same project settings.  And also, I have another PC running XP, which runs fine as well. 

    Not only that, but when I run on the problem laptop, I do see the EZ430 unit as a COM port, and can talk to the device with a terminal emulator.  So it's just the CCE software that's having a problem, and only on this PC.

    What's up with that??  Anyone?  Anyone?   ... Brandon?

    Thanks guys,    Sean

  • In reply to Sean2301:

    No, I didn't. It happened with both CCE3 and IAR so I gave up. I am using an older desktop I had around with XP and that works fine. Sorry for not being able to help.

  • In reply to claudiu:

    Mmm, looks like I'll go your way on this.

    I tried what I could think of, but to no avail.  Would like to be able to use this tool on the (laptop) machine, which is what I intended it for when I bought it (!) but don't want to spend too much time working it.

    Thanks for you help though, appreciate the response !

    Sean

  • In reply to Sean2301:

    Quick update -

    With help from TI support (Billy), we identified the problem and got CCE to initialize and download the EZ430-RF2500.

    The problem was an apparent conflict with an HID device = the HP remote control for this laptop.  The solution was to open Control Panel, and uninstall the HID device.  When doing this, the EZ430 works fine.

    Note that every time I power up the laptop, the HP remote control HID reloads, so that the uninstall needs to be performed each time.  (This could be fixed but not a big deal, and means that in the event we want to use the remote control, it will still load automatically on power-up.)

    So, check this out if you're still having this problem; look at COM ports and HID devices, and remove anything unneeded that might conflict...

    Sean

  • In reply to Sean2301:

    It took me a while to try this again but I just did and it worked! Thanks a lot for following up and posting the solution.

    What fixed it for me was to remove one of the HID Keyboard devices under Keyboards in Device Manager (Win XP) - there were 2 of them, removing just one was fine.

    Again, thanks for your help!

  • In reply to claudiu:

    Hi, I tried this to remedy a similiar problem under Vista, but still same error message could not find emulator. I removed the HID devices and allowed reinstall.

    Is there a permission's issue in Vista since CCE invokes the target server outside of its process space?

    TIA for any insight.

  • In reply to BrandonElliott:

    Brandon,

    I have seen this problem in Vista - Windows does not correctly typify the device during install in Vista and the "Could not initialize device interface" occurs when launching any debug. Is there an updated driver for the MSP 430 and CCE 3?

     

    Regards, Jerry Campbell