This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

MSP430 LaunchPad - Mac OS X

Sorry for reopening this answered topic.

I could not get the TUSB3410 driver to work with the Launchpad on Mac OS X. I recompiled the driver with the correct product/vendor/bcddevice ID.

Using the USB prober tool from Apple, I saw that the system looked up com.ti.VCPSerial and found that all 3 IDs matched. The final score was 100000 with a wildcard of 0.

In the debug version of the driver, I saw a lot of "timing out" messages - in the end, the tty ports were not created. For reference, the Launchpad's FET430UIF has a device id of 62514 and a bcddevice of 256, with only 1 bcdconfiguration.

Please help me with this if possible.

 

Harsha

4 Replies

  • The TUSB3410 on the launchpad (and also the EZ430-RF2500 and Chronos) does not contain a "normal" serial port of the sort that the TI-distributed VSP driver uses (and is used on the EZ430-F2013)  It has custom software that implements a HID device for use bye spybiwire, and a CDC ACM serial port for the serial port (which is not done in a way that the Mac seems to like.)  You should be able to get debug/load working by following the instructions on the mspdebug site ( http://mspdebug.sourceforge.net/faq.html ), but I think the serial port is still an unsolved mystery.

    I'm looking forward to the day when that whole rather kludegy USB/JTAG interface is replaced with one of the new USB-capable MSP430 cpus.  But I'm not holding my breath.

     

  • In reply to westfw:

    Hi,

    sad to say, but there is NO official Apple OS X support for any MSP430 tool at the moment. Look at http://processors.wiki.ti.com/index.php/MSP430_LaunchPad_(MSP-EXP430G2) ; there is a link which will give you some (unsupported info) how to set up a GCC toolchain on OS X (http://processors.wiki.ti.com/index.php/MSP430_LaunchPad_Mac_OS_X).

    Rgds
    aBUGSworstnightmare

  • In reply to aBUGSworstnightmare:

    Thanks for the info, westfw and BUGS. Special thanks to westfw for the codeless kext which got the HID interface working.

    I really did try by modifying Apple's USBCDC.kext to include the product/vendor ID for the launchpad (since other devices like the Sharp Zaurus which expose a CDC/ACM are listed there), but still no luck. Looks like I have to use Linux for non code limited usage. 

     

     

  • In reply to Harsha Chenji:

    As an aside, I was trying to use the TUSB3410 driver by Dan. I am getting timeout issues, which probably means an unsupported chipset/firmware.

     

    I noticed some firmware images in the FWImages directory in the driver sources - Is it wise to either use the 3410 image provided to flash the launchpad or dump the launchpad's firmware and recompile the driver? Has anyone tried that?

     

    Thanks

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.