This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • TI Thinks Resolved

DS90LV049: Communication error after doing ESD test

Expert 4285 points

Replies: 7

Views: 100

Part Number: DS90LV049

Hi Expert,

My customer have an issue about communication error after doing ESD test.

LVDSIC.xlsx

This behavior is kept until Power OFF/ON. It seem the latch.

Customer guess the ESD was coming from 9pin.

Q1, Could you please let me know the reason of this behavior?

Q2, Can you provide an equivalent circuit diagram for 9-pin and 16-pin input circuits?

Q3, Please tell me recommended terminate method for 9pin/16pin.

        Current condition

        /EN pulldown with 1kohm. If they change pulldown resister to 0ohm, it was improved.

Thanks

Muk

  • what kind of ESD test? did they notice  supply current changes before and after ESD test?

  • Hi Muk-san,

    Can you provide more details about the ESD test? How are they carrying out this test?

    A1, If the output is staying high this must mean EN is not high and /EN is not low. Have they measured the voltage on these pins when the issue happens? 

    A2, We cannot provide an equivalent circuit diagram for 9-pin and 16-pin input circuits.

    A3, I would recommend the same termination scheme the EVM uses: http://www.ti.com/lit/ug/snlu195/snlu195.pdf, so a 0ohm pull-down resistor. 

    When you say "it was improved" with a 0ohm pulldown, do you mean they no longer see the issue?

    Regards,

    I.K. 

  • In reply to I.K. Anyiam:

    Hi I.K.-san

    Thank you for your answer.

    ESD test is +\-7.5kHz~+/-4kV to frame GND

    Regarding Q2

    Could you please provide the information for below,

    - Are there the protection diodes for 9/16pin?

    -  Are there the internal pull down/or pull up for 9/16pin?

    - Is it CMOS input?

    Regarding Q3

    Is the following my understanding correct?

    Forced Low : Pulldown with 0ohm.

    Control device enable by input signal : pull up to Vcc with 10koohm (open drain)

    Thanks

    Muk

  • In reply to Yusuke Mukuno:

    Hi I.K-san,

    Could you please support my question?

    I need to answer by 20th Jan.

    Also, Customer want to know the reason of stronger to ESD with 0ohm pulldown. Can you explain for this from device internal circuit?

    Thanks

    Muk

  • In reply to Yusuke Mukuno:

    Hi Muk-san,

    This is an old device that was inherited from National, so unfortunately I don't have any information on the internal circuitry. However, the datasheet does state that there are internal pull-down current sources present at both pins.

    Regards,

    I.K.

  • In reply to I.K. Anyiam:

    Hi, I.K.

    Customer cannot believe that TI don't have internal circuit information of mass produced product...

    Customer request is below,

    If we don't find this information, could you please check with measurement about clamp diode and pulldown current sources.

    Could you please support it? This issue is occurred during customer mass-production phase. they need urgent support. please help us.

    Muk

  • In reply to Yusuke Mukuno:

    Hi Muk,

    There is an internal diode from the EN signal to GND for ESD protection. The connection takes a lot current, so with a 1k resistor it seems it has issues latching up, and causes the communication error. This is why 0ohm works better.

    The only measurement information we have for the clamp diode is the VCL specification in the datasheet: -18mA @ -0.6V.

    Regards,

    I.K. 

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.