This thread has been locked.
If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.
The "run together" code listing (above) reveals "GPIOPinConfigure( GPIO_PA0_TOCCP0);" and then lists, "GPIOPinTypeTimer(GPIO_PORTN_BASE, GPIO_PIN_0)" - is not poster's "conflict" easily noted?
Your "change" was not (especially) clear - was it? Making it "hard" for your helpers - does NOT serve your interests - does it?
Let's look at a "proper" (more readable) version of your latest code. (still SQUISHED together - adding space does NOT increase your "cost" here - and makes the code FAR MORE READABLE!
GPIOPinConfigure(GPIO_PA0_T0CCP0 ); // Here you've "config'ed" GPIO_PA0 as a Timer
GPIOPinTypeTimer(GPIO_PORTA_BASE, GPIO_PIN_0); // And here you've "typed" GPIO_PA0 as Timer. *** Good so far!
And then arrives:
GPIOPinTypeGPIOInput(GPIO_PORTA_BASE, GPIO_PIN_0); // Have you not - thru this action - "invalidated your (earlier/above) Timer Settings" for PA0?
There are many, many code examples - should you not search for - then find - then seriously review them? It is doubted that (any) of those examples will "switch the previously set pin from "Timer" to GPIO Input - as you've done... Remove that line of code (just above) - and run/report...