This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.


Part Number: SIMPLELINK-CC2640R2-SDK

Good Morning,

I am a software developer that working in Marelli.

In my work, I'm starting to use Code composer studio.

I have a trouble that comes out when I try to import a project example from "resources explorer" in the software Code Composer Studio. 

I attach a screenshot of the error.

Could you help me? 

Thank you.

If you need more information I will provide it to you.

Alessandro Samorì

  • Hello,

    I am also having issues downloading that version of the SDK. We are investigating.

    Note: That version of the SDK is quite old. Is there any particular reason you are tying to access such an old version? Are you using a revision of the device that requires that old version?



  • Turns out that the old 2.30 version of the SDK was removed from the server intentionally. Resource Explorer should have been hiding those old version. They were likely removed because they are obsolete and no longer supported,

    My question regarding your interest in that old version remains. Why are you interested in it?



  • Hi KI,

    I am not interested in a particular version of the SDK but I'd like to import an example project of SPI slave. From the Resource explorer I chose Software-->SimpleLink CC26X2 SDK (>Examples-->Development Tools--> CC26x2R Launchpad-->TI drivers-->spislave-->TI-RTOS-->CCS compiler-->spislave. For now I'm not using a physical board. I will start to use a board of this kind of family (CC26x) next week. Anyway, if I try to import another example of spislave from a different path (the path belongs to CC32xx SDK-, I receive the a similar  error.

    I'm following the instruction for importing a project from this link 

    Thank you,

    A. S. 

  • Can you try the troubleshooting steps in section and below:

    Also, what version of CCS are you using?



  • In the meantime, you can try a workaround of manually downloading the SDK and installing it yourself.

  • Ok thanks.

    I use the 10.3.0 version.

    How can I manually download the SDK? Do I have to do from Code Composer studio?


  • You can download from

    For CC26x2, see:

    Did you try the troubleshooting steps for the Resource Explorer issue?



  • I have just tried to delete the folder .metadata in the folder of my workspace (paragraph 9.4.3.) but, after restarting code composer studio, it gives me the same error. I downloaded the SDK from your link. Thanks. Please give me one or two day in order to install the SDK following the security policy of my company.

    Thank you so much,

    Alessandro. S. 

  • The engineers have analyzed the errors and determined that the issue is that Resource Explorer is being blocked by your network firewall/proxy. One thing to try is to set the proxy configuration in CCS:



  • Hi,

    Ok I got it, thanks.

    I verified the error with my ICT.

    Now, when I try the import, it gives me this error:

    "There was an error installing, please resolve before attempting to import again - EPERM: operation not permitted, lstat 'C:\ti\ccs1030\.tirex-temp\install-download-c2502fce-5b51-4b1a-b31f-9cfb4d29a539\'"

    Do you know how to solve this one?

    (in parallel, I'm doing the manual installation. I will update you about it)

    Thank you,

    Alessandro S.

  • Could I ask you also the URL that connect from backend (that URL used by "import" procedure)? Thanks

    Alessandro S.

  • "There was an error installing, please resolve before attempting to import again - EPERM: operation not permitted, lstat 'C:\ti\ccs1030\.tirex-temp\install-download-c2502fce-5b51-4b1a-b31f-9cfb4d29a539\'"

    I've never seen this one. It looks like a permissions issue of some sort. Perhaps try temporarily disabling any anti-vrius/security software running on your PC?

  • I just realized that the error message is for the old 2.30 version of the SDK. That version is not supported and actually has been removed from the server. I get a 404 error when I try to download/install it. I'm not sure how you even got some zip to be downloaded. Are you able to download/install a later SDK version from Resource Explorer?

  • My ICT made some rules to allow the "import" method from Resource Explorer and the procedure tries to download the .zip file with that version (the only version that Code Composer Studio shows me from Resources Explorer). But I have just seen that the path " C:\ti\ccs1030\.tirex-temp\install-download-c2502fce-5b51-4b1a-b31f-9cfb4d29a539"  is empty. Probably for the reason you mentioned (version removed from the server). The only SDK file I have been able to download is "simplelink_cc13x2_26x2_sdk_5_10_00_48.exe" from the link you provided me (  ).  Probably when I install the .exe I will able to import the sdk in my workspace? Let me know if I understand properly. Thank you.

    Alessandro S.

  • the only version that Code Composer Studio shows me from Resources Explorer)

    The "SimpleLink CC13x2 SDK" has been replaced by "SimpleLink CC13x2 CC26x2 SDK". Don't use the former as it old has now obsolete (we should actually have been hiding it). That is why the last version of that obsolete package is 2.30. Later versions are rolled into the  "SimpleLink CC13x2 CC26x2 SDK" package. That is the one you should be using.


    I am wondering how the .tirex-temp folder is in your CCS installation. It typically should be in the root C:\ti folder. Is this something your IT configured?

    Probably when I install the .exe I will able to import the sdk in my workspace?

    Yes, it will install in C:\ti (which is the desired default) and you can then use it with CCS and import projects from Resource Explorer (or manually if you wish).



  • Hello,

    I saw the change on Resource Explorer. Now, I can see the latest version

    Anyway installed the "SimpleLink CC13x2 CC26x2 SDK" package that I dowloaded from website. I installed it in the directory C:\ti. 

    Now, I would like to import the project spislave in my workspace (C:\ti\ccs1030\myworkspace ) and to do it, I select "import project" from the "Getting Started" of CCS. I choose the directory from my installed package:

    When I press "Finish", an error appears:

    Did I do the wrong procedure?


    Alessandro Samorì

  • That is odd. When importing the project, you should see something like:

    Is there a spislave_CC26X2R1_LAUNCHXL_tirtos_ccs.projectspec file in that directory? If so, can you atatch it to this thread?



  • Hello,

    I checked in the directory in CCS and there is the file:

    but when I try to import it from ccs it is not recognized.

    However, I deleted the file ".project" that you can see at the top of the folder and I tried again the same "import". After this change it works!!

    This file probably was produced when I imported in a erroneous way the project. I wrongly imported the directory "/spislave" and CCS gave me an error. 

    In any case I understood a good way to have a project imported in my workspace:

    -Download the SDK from the TI website

    -Install it

    -import the project by choosing the folder that contains the file .projectspec

    Thank you for your support