This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

Error connecting to the target: Could not find device (or device not supported)

Other Parts Discussed in Thread: MSP430G2231

I have spent the last two evening after work tying to get this to work. I have tried everything I could find online to no avail. So here is my story.

I have always had issues getting CCS to connect to my MSP430 Launchpad with G2231, having to click retry 3 to 5 times. So this weekend it just stops working. No mater how many time I hit retry, nothing. Restart, unplug, uninstall drivers, and retry. This is all running CCS 5.1 so I figure 5.2 might fix it. It doesn't so I think maybe dropping back to 4.2 will do the trick, it doesn't.

Please Help!

  • Casey Cotter said:

    Error connecting to the target: Could not find device (or device not supported)

    Report back your results after you try testing each of these variables one at a time:

    1. Code Composer Studio.  Instead download your compiled code using something else.  For example FET-Pro430 Lite
    2. MSP430G2231.  Remove this part and try a different MSP430.  Each LaunhPad ships with two devices.  Your code will need to be specific for that device.
    3. Your computer.  Try another computer with FET-Pro430 Lite
    4, Your compiled code.  You could try a free code limited version of IAR to complie and connect.
    5, The USB cable.  Do you have a cat that likes wires?
    6, The LaunchPad board.  They're cheap enough, you could buy another one to try.

    You may find this post helpful.

    Is there a tool like LM Flash Programmer for the LaunchPad?

    Which MSP430Ware example are you trying?

  • Hi,

          I had this problem often and I figured out that My power and ground connections are not fine. Well I am programming MSP430 on my development board from Launchpad. I don't know what is your case. Well If you are programming 2231 which is residing some where other than Launchpad you can try this.

    1. you can look in to forums with title "JTAG conncetion problem" You may find your problem solution here

    2.I strongly recommend that you try another launchpad (jason said)



  • I find that LauchPad is very sensitive to quality of USB cable used, one that came in the box did not work well for me. Changing cable to better one resolved connection issues.

  • Thank you all for your responses. I borrowed a launchpad from a friend and put my G2231 on it and presto worked like a champ. I am glad I tried this one first. I had connection issued with the board from day one so it makes sense. Guess I need to get a new one. Thanks again for all the help. 

  • Casey Cotter said:
    Guess I need to get a new one.

    Sometimes (way too often) it's really just the USB cable. The cheap cable that comes with the LaunchPad is prone to shielding or wire cracks. However, a high quality cable, even in large quantities, costs almost more than the whole LaunchPad.

**Attention** This is a public forum