This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

MSP430FR5739: Update firmware of MSP-FET-debugger for "MSP-EXP430FR5739 FRAM Experimenter Board".

Part Number: MSP430FR5739
Other Parts Discussed in Thread: MSP-FET, MSP-EXP430FR5739, UNIFLASH, MSP430F1612


I have "MSP-EXP430FR5739 FRAM Experimenter Board". This board has a built-in debugger (MSP-FET). With firmware version

Can I update the firmware of this debugger to a newer one?

  • Hi,

    If you try to load a program with the latest version of Code Composer, it should automatically update the firmware to the latest version.

  • Thank you for your answer!

    I am using IAR (v7.12.1). Is it possible to do this update without installing CCS? Via IAR or a third party utility?

    I have installed: MSPFlasher_1.3.20  and uniflash_6.2.0. Can I do this with these utilities?

  • Hi,

    I would expect the latest version of Uniflash to update your firmware also if needed.


  • Hi!

    Unfortunately, the latest version of Uniflash doesn't know about my board:

    I also tried to select my microcontroller in this menu:

    But Uniflash doesn't seem to connect to my MK:

    (I have tried all 3 USB)

    The program gets stuck in this state.

    But in this case, the IAR connects normally to the board.

    Why can't Uniflash connect to my board???

  • Hi,

    It's not clear to me why Uniflash isn't connecting to your platform.(you could post this question to the tools forum)  I would recommend that you try using Code Composer instead(which is a free download).


  • Hi Leo!

    I already tried it (yesterday). The CCS (of the latest version) properly connects to my board, loads software there, allows debugging ... but unfortunately - it does not update the firmware of MSP430F1612.  :(((

  • Hi,

    The firmware will only be updated if its needed. If debug is working properly, there's no need to update the FET firmware.


  • Hi!

    Yes, it work properly, but... very slowly. :((

    And the backchannel UART is slow (<=9600). Although the second thing is certainly fixable: I have already connected an external USB<->UART instead.

  • Hi,

    I'm not sure what might be causing things to run slowly. Do you find things are slow regardless of which example project you are running? 


  • Hi!

    I want to say that it happens very slowly:

    connecting the debugger to the board;

    downloading firmware;

    and all further actions - step-by-step debugging, etc.

    I compare with debugging on other platforms: Cortex-M (via JLink), STM8 (via STLink), etc. Since I have projects on these platforms.

    But okay - this is not a very serious problem. I have already replaced the Backchannel UART with an external USB-UART unit.

    Another problem worries me more: UART.RX does not work in LPM3. Only in LPM1.

    UART.RX - does not work. UART.TX - works fine.

    UART clocking from SMCLK (which clocking from DCO). Baudrate =9600.

    It looks like this: As long as none of the LPMx modes is turned on, UART.RX works properly (UCRXIFG interrupts - occur, data-bytes from UCAxRXBUF is read correctly). Then the program turns on the LPM3 mode and after that UCRXIFG interrupts continue to occurs, but good data-bytes is no longer received (data is received with the set one of the error bits in UCAxSTATW, read from UCAxRXBUF - returns broken data).

    If do the same, but replace LPM3 -> LPM1, then the program will continue to work correctly - data-bytes is correct.

    UART.TX works correctly in any mode - LPM1 or LPM3.



**Attention** This is a public forum