The TI E2E™ design support forums will undergo maintenance from Sept. 28 to Oct. 2. If you need design support during this time, contact your TI representative or open a new support request with our customer support center.

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

AM5728: IDK machine learning out of box examples crashing

Part Number: AM5728

Hello,

I downloaded the latest PLSDK 6.03.00.106 image and created an SD card to run the TIDL ssd_multibox example. However, trying to launch any of the matrix gui examples for me just crashes. Launching the ssd_multibox example returns:

TIOCL FATAL: Failed to open EVE message queue

I have tried to look at the remoteproc logs for EVE in /sys/kernel/debug/remoteproc/remoteproc0/trace0 but on my serial console this returns a bunch of non-ascii characters.

I also looked through my boot log and never see a confirmation that firmware is loaded on the DSPs or EVEs although there are firmware files in /lib/firmware/*ipu1* etc. However, I do not have any firmware files in /run/media/mmcblk0p1.

Finally I do see a couple messages from omap-mailbox:

[  273.112854] omap-mailbox 48840000.mailbox: Try increasing MBOX_TX_QUEUE_LEN
[  273.119967] omap-rproc 58820000.ipu: PM mbox_send_message failed: -105

I verified that CMEM is running on my EVM and there's only 2 EVEs on the AM5728 so I shouldn't need to increase CMEM size as per the documentation.

Any suggestions on what else I should try to get these examples running? I'm using the AM5728 IDK and have verified that the camera input works as expected.

Munan

  • Hi Munan, I tested my AM5728 with PSDKL ti-processor-sdk-linux-am57xx-evm-06.03.00.106-Linux-x86-Install.bin and it worked OK. I was able to run ML demos from matrix GUI and from console. From console I tested ./ssd_multibox with camera input by running:

    root@am57xx-evm:/usr/share/ti/tidl/examples/ssd_multibox# /etc/init.d/matrix-gui-2.0 stop
    root@am57xx-evm:/usr/share/ti/tidl/examples/ssd_multibox# ./ssd_multibox -i camera -f 500

    Maybe there is something wrong with your SD card. How did you create it?. For your reference I created using linux scripts (sudo <SDK INSTALL DIR>/bin/create-sdcard.sh). I created with 2 partitions and default image tisdk-server-extra-rootfs-image-k2g-evm.tar.gz

    I also can run below commands to check number of EVE's

    #cat /sys/kernel/debug/remoteproc/remoteproc0/trace0

    On the other hand, are you testing on TI's IDK or in your custom board?

    Thank you,

    Paula

  • Hi Paula,

    I'm downloading the img from the sdk download page and using win32 disk imager to create the SD card. I will try the linux scripts instead and see if that makes a difference. 

    Running on the AM5728 IDK.

    Munan

  • Hi Munan, it will probably make a difference, below is from another E2E. I remember I faced this issue with AM57x PSDKL image some time back 

    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

    When creating and SD card using windows PSDK image, there are two copies of IPU1 firmware on the SDCard.  One in the VFAT partition for early reboot, the second one in Linux partition /lib/firmware.  They need to be the same.

    Our Linux create-sdcard.sh takes care of this for you. But, if you created your SD card in any other way, there could be a mistmatch, and you will need to manually copy the correct one:

    Could you please try below and let me know if this works for you?:

    • cp /lib/firmware/dra7-ipu1-fw.xem4.opencl-monitor /run/media/mmcblk0p1/dra7-ipu1-fw.xem4
    • reboot
    • re-test

    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

    thank you,

    Paula