This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

Errors running builder 'CDT Builder' on project

Other Parts Discussed in Thread: NOWFLASH, CCSTUDIO, SYSBIOS

I am getting that error now after working hard getting this project under CC 5.2x and under a new (but similar) hardware platform.

Can someone please take a look at the attached pic and tell me if you've seen this before, what causes it, and how to work around it?

Thanks In Advance,
johnw 

  • Hi John,

    can you please provide a bit further information?   Are you using the 5535 or 5515?  I see elements for both.  However, one thing as well.  Was your original project working without issue?   Are you using CCS projects?  I notice two C projects in your screenshot.   You should be using CCS projects.

    Any further info would help.  Have you tried a fresh workspace?   Are these imported or new projects?

     

    Best Regards,
    Lisa

  • Hello Lisa,

    I have both the 5515 and 5535.  I would like to run the debugger on the 5535.   Note I just got a 'clean' compile on the 5535 and when I tried to start the debugger I saw this error for the first time.

    I think this is related to a bug that will be fixed in v5.3 - correct?

    Yes - the 'original' project ran - but that was also with the '5515 in a previous version of CC.  I was also able to get that running on the '5515 under CC 5.2x - I just had this problem pop up when I tried to enable the debugger for the 5535.

    I thought since I was using CC and it's a project - that means it's a CCS project.  If not - can you please explain?  I was going to try the 5.3 CR1 to see if they've fixed this error.

    I have tried a fresh workspace - does the same thing.  Can't even build this project now.  

    Thanks,
    John 

  • Hi John,

    ok, yes 5.3 may well be worth a try but first I would recommend making sure you use CCS projects.  File->New->CCS Project.   A CCS project is necessary  (unless you have a special case with gcc and/or cross compiling).

    Try that and please keep us informed.

    Best Regards,
    Lisa

  • Hello Lisa,

    I tried a lot of different things, including installing and trying the 5.3 beta - but it did the same thing.  

    I made a CCS project (v5.2) completely from scratch - redid everything - and now at least the debugger starts.

    I noticed some type of project scanning message or something like that with the original project before seeing the error message pop up.

    Thanks for telling me about the 'CCS project' issue with CCS.  It is fairly confusing and somewhat non-intuitive since you're in CCS and you have a project once you've imported it.

    Regards,
    johnw 

  • Hi John,

    so are you up and running now?

    Best Regards,
    Lisa

  • Hello Lisa,

    Yes I am.  And thanks for your help.

    I must admit, I spent a little part of this past weekend looking at what other code development options exist for TI's DSP's.

    Being up against an issue like this is disappointing and doesn't bode well with productivity.  I found some posts in the past in which the CDT options could be changed but I could not find that in the current tools.

    Are the core of the tool development people still in Stafford?  Just wondering.  As an FYI - I used to work in Stafford once-upon-a-time.

    Thanks Again Lisa,
    John W. 

  • So what is the fix for this?    I am getting the same problem on 5.3.0.00090 and I am not doing any migration.  My project was working fine, I didn't change or do anything new and now I am getting the CDT java bug.

    Errors occurred during the build.
    Errors running builder 'CDT Builder' on project 'jviom'.
    java.lang.NullPointerException

    And John is right.  This kind of random incomprehensible bug that has seemingly nothing to do with anything I am doing is very frustrating and a killer to productivity.  

    HOW DO I FIX THIS?

    My toolset:

    ARM BIOS6 6.34.2.18 com.ti.bios.arm.win32.feature.group Texas Instruments
    ARM Compiler Tools 5.0.4 com.ti.cgt.tms470.5.0.win32.feature.group Texas Instruments
    ARM Compiler v5.0 Help 5.0.0.201210291916 com.ti.cgt.arm.5.0.help.feature.group Texas Instruments
    ARM IPC 1.25.0.04 com.ti.ipc.arm.win32.feature.group Texas Instruments
    ARM XDCTools 3.24.5.48 com.ti.xdctools.arm.win32.feature.group Texas Instruments
    Autotools support for CDT 3.0.1.201206111645 org.eclipse.cdt.autotools.feature.group Eclipse CDT
    BIOS 6 6.34.2.18 com.ti.bios.base.win32.feature.group Texas Instruments
    C/C++ Development Tools 8.1.0.201206111645 org.eclipse.cdt.feature.group Eclipse CDT
    C/C++ GCC Cross Compiler Support 1.1.0.201206111645 org.eclipse.cdt.build.crossgcc.feature.group Eclipse CDT
    C/C++ GDB Hardware Debugging 7.0.0.201206111645 org.eclipse.cdt.debug.gdbjtag.feature.group Eclipse CDT
    C/C++ Memory View Enhancements 2.2.0.201206111645 org.eclipse.cdt.debug.ui.memory.feature.group Eclipse CDT
    C/C++ Remote Launch 6.0.0.201206111645 org.eclipse.cdt.launch.remote.feature.group Eclipse CDT
    C2000 BIOS6 6.34.2.18 com.ti.bios.c2000.win32.feature.group Texas Instruments
    C2000 Compiler v6.1 Help 6.1.1.201211281204 com.ti.cgt.c2000.6.1.help.feature.group Texas Instruments
    C2000 Device Support 4.1.0.3 com.ti.c2000.support.win32.feature.group Texas Instruments
    C2000 Emulation Flash 1.0.0.2 com.ti.c2000.flash.setup.win32.feature.group Texas Instruments
    C2000 IPC 1.25.0.04 com.ti.ipc.c2000.win32.feature.group Texas Instruments
    C2000 XDCTools 3.24.5.48 com.ti.xdctools.c2000.win32.feature.group Texas Instruments
    C2800 Compiler Tools 6.1.2 com.ti.cgt.c2000.6.1.win32.feature.group Texas Instruments
    CCS NowFlash Emulators 5.3.0.0 com.ti.ccstudio.nowflash.win32.feature.group Texas Instruments
    CCSINIT 5.1.0.0 com.ti.ccstudio.ccsinit.win32.feature.group Texas Instruments
    CDT Visual C++ Support 1.0.0.201206111645 org.eclipse.cdt.msw.feature.group Eclipse CDT
    Code Composer Studio Base Components 5.3.0.00368 com.ti.ccstudio.base.feature.group Texas Instruments
    Code Composer Studio IDE ARM Components 5.3.0.201211071700 com.ti.ccstudio.tms470.feature.group Texas Instruments
    Code Composer Studio IDE C2000 Components 5.3.0.201211071700 com.ti.ccstudio.c2000.feature.group Texas Instruments
    Code Composer Studio IDE Main Feature 5.3.0.201211071700 com.ti.ccstudio.idemain.feature.group Texas Instruments
    Code Composer Studio IDE Workflow 5.3.0.201211071700 com.ti.ccstudio.workflow.feature.group Texas Instruments
    Compiler Tools On-line Documentation 1.1.0.0 com.ti.cgt.dmed.win32.feature.group Texas Instruments
    Debug Server 5.3.0.368 com.ti.ccstudio.debugserver.win32.feature.group Texas Instruments
    DVT - Graph Visualization 3.3.0.201209281235 com.ti.dvt2.graph.visualization.feature.group Texas Instruments
    DVT - Profiler Analysis Manager 3.3.0.201209281235 com.ti.dvt2.profileanalysismanager.feature.group Texas Instruments
    DVT - RTA Feature 3.3.0.201209281235 com.ti.dvt2.rta.feature.group Texas Instruments
    DVT - Trace Control 3.3.0.201209281235 com.ti.dvt2.trace.control.feature.group Texas Instruments
    Eclipse CVS Client 1.3.200.v20120525-1249-7B79FJJAkF7BF7SDL5EAJT org.eclipse.cvs.feature.group Eclipse.org
    Eclipse EGit 2.0.0.201206130900-r org.eclipse.egit.feature.group Eclipse EGit
    Eclipse Help System 1.4.0.v20120528-1717-8P7vFOTFK_Qj4JmDIQXJ8Tn org.eclipse.help.feature.group Eclipse.org
    Eclipse Platform 3.8.0.I20120608-1200 org.eclipse.platform.ide null
    EGit Import Support 2.0.0.201206130900-r org.eclipse.egit.import.feature.group Eclipse EGit
    EPP Common Package Feature 1.5.0.20120202-1420 org.eclipse.epp.package.common.feature.feature.group Eclipse Packaging Project
    Equinox p2 Discovery 1.0.100.v20120524-0542-4-Bh9oB58A5N9L28PCQ org.eclipse.equinox.p2.discovery.feature.feature.group Eclipse.org - Equinox
    Equinox p2 Provisioning for IDEs. 2.2.0.v20120524-0542-62DG9JXTlSiz-UbcP0w0KGe8CBOP org.eclipse.equinox.p2.user.ui.feature.group Eclipse.org - Equinox
    Image Analyzer 3.3.0.201209281235 com.ti.dvt2.via.ccs.feature.group Texas Instruments
    IPC 1.25.0.04 com.ti.ipc.base.win32.feature.group Texas Instruments
    IPC (Multicore and I/O) (IDE Client) 1.25.0.04 com.ti.rtsc.IPC.product.ui.feature.group Texas Instruments
    IPC (Multicore and I/O) (Target Content) 1.25.0.04 com.ti.rtsc.IPC.product_1.25.0.04.feature.group Texas Instruments
    JavaScript Development Tools 1.4.0.v201111090639-7H7DFeHFC7sRemSZgYbe4 org.eclipse.wst.jsdt.feature.feature.group Eclipse Web Tools Platform
    Log View 1.0.300.v20120530-1435 org.eclipse.ui.views.log Eclipse.org
    LWInstaller 5.3.0.00090 com.ti.ccstudio.installer.win32.feature.group Texas Instruments
    Marketplace Client 1.1.1.I20110907-0947 org.eclipse.epp.mpc.feature.group Eclipse Packaging Project
    Mylyn Context Connector: C/C++ Development 5.4.0.v20120612-0600 org.eclipse.cdt.mylyn.feature.group Eclipse Mylyn
    Mylyn Context Connector: Eclipse IDE 3.8.0.v20120612-0600 org.eclipse.mylyn.ide_feature.feature.group Eclipse Mylyn
    Mylyn Context Connector: Team Support 3.8.0.v20120612-0600 org.eclipse.mylyn.team_feature.feature.group Eclipse Mylyn
    Mylyn Task List 3.8.0.v20120612-0600 org.eclipse.mylyn_feature.feature.group Eclipse Mylyn
    Mylyn Task-Focused Interface 3.8.0.v20120612-0600 org.eclipse.mylyn.context_feature.feature.group Eclipse Mylyn
    Mylyn Tasks Connector: Bugzilla 3.8.0.v20120612-0600 org.eclipse.mylyn.bugzilla_feature.feature.group Eclipse Mylyn
    Mylyn WikiText 1.7.0.v20120612-0600 org.eclipse.mylyn.wikitext_feature.feature.group Eclipse Mylyn
    Remote System Explorer End-User Runtime 3.4.0.201205300905-7L7IFBV83omxZWwIDyHWipb2Sz-f org.eclipse.rse.feature.group Eclipse TM Project
    REQUIRED CCS Update Installation Tool 5.2.0.201204111758 com.ti.ccstudio.p2tool.feature.group Texas Instruments
    ROV 3.3.0.201209281235 com.ti.dvt2.rov.feature.group Texas Instruments
    RTSC/XDCtools (IDE Client) 3.24.5.48 org.eclipse.rtsc.xdctools.product.ui.feature.group Texas Instruments
    RTSC/XDCtools (Target Runtime Support) 3.24.5.48 org.eclipse.rtsc.xdctools.product_3.24.5.48.feature.group Texas Instruments
    Spectrum Digital Emulators 5.2.0.07 com.sd.ccstudio.emulation.win32.feature.group Spectrum Digital
    SYS/BIOS (IDE Client) 6.34.2.18 com.ti.rtsc.SYSBIOS.product.ui.feature.group Texas Instruments
    SYS/BIOS (Target Content) 6.34.2.18 com.ti.rtsc.SYSBIOS.product_6.34.2.18.feature.group Texas Instruments
    System Analyzer (UIA Target) (IDE Client) 1.1.1.14 com.ti.uia.product.ui.feature.group Texas Instruments
    System Analyzer (UIA Target) (Target Content) 1.1.1.14 com.ti.uia.product_1.1.1.14.feature.group Texas Instruments
    Target Management Terminal 3.3.0.201205300905-7N7FF8N7iMlAUojUZPXmWeON org.eclipse.tm.terminal.sdk.feature.group Eclipse TM Project
    Third-Party Components for GMF Runtime 1.5.0.v20110426-2230-7P8W6FHV2CYms9gAtyKPaw311A16 org.eclipse.gmf.runtime.thirdparty.feature.group Eclipse Modeling Project
    TI Emulators 5.1.45.0 com.ti.emulation.pack.win32.feature.group Texas Instruments
    TI Simulators 5.3.3.0 com.ti.sim.pack.setup.win32.feature.group Texas Instruments
    Trace Analyzer 3.3.0.201209281235 com.ti.dvt2.trace.ccs.feature.group Texas Instruments
    UIA 1.1.1.14 com.ti.uia.win32.feature.group Texas Instruments
    XDAIS 7.21.1.07 com.ti.xdais.7.21.win32.feature.group Texas Instruments
    XDAIS (IDE Client) 7.21.1.07 com.ti.rtsc.XDAIS.product.ui.feature.group Texas Instruments Inc.
    XDAIS (Target Content) 7.21.1.07 com.ti.rtsc.XDAIS.product_7.21.01.07.feature.group Texas Instruments Inc.
    XDCTools 3.24.5.48 com.ti.xdctools.base.win32.feature.group Texas Instruments
    Xulrunner 10.4.0 com.ti.ccstudio.xulrunner.win32.feature.group Texas Instruments

  • Same issue, and in my CCS v5.4 is caused by switching compiler version. These are the steps that cause the exception.

    1) I've imported a project made with an older version of ARM compiler. Everything works fine, but there is an annoying warning message:

    CCS5 finds that the project was created with 4.9.0 ARM compiler, but that compiler is not installed. The installed one is rev 5.0.4. No matter, compilation works and I get a nice and clean bin file.

    2) Tired of that warning message, I decided to select the right compiler version in project options:

    Then I press the "OK" button, clean the project, delete the "Debug" folder (the active configuration is "Debug").

    3) I rebuild the project, and the error comes out:

    4) From now on, I cannot switch back to previuos compiler version, since it's now shown in compiler selection box, and the whole project is stuck in a frozen state.

    I can't restore it, and the only solution is throw it away in recycle bin and start again from scratch.... No way!!!!!!!!

    Any suggestion?

  • I am having the same issue with same reproduction steps as eugenio with CCS 5.3 and the MSP toolchain. Let me know if you find a solution.

  • Is there any resolution to this?

    I get the same error message after switching code gen tools on CCS 5.4.0.00091

     from v6.0.2  to v6.1.3

    Occurs every time I compile. If I try to switch back to the older code gen tools, the problem is still there!

  • I've found that this problem is not related to code generation tool version, but occurs when there is a mismatch between code generation tool version in project settings and the actual tool installed. 

    Once the message comes out, that's a non return point! The only working method to restore the project is:

    • switch back to previous version on Code Composer studio (rev. 5.3);
    • open the same workspace with the older ccs
    • open the project, set the actual version of compiler in project settings, clean and rebuild.
    From now on, project is fixed and you can use ccs rev 5.4.
    Generally speaking, CCS based on ECLIPSE is not as stable as one could expect from a Texas Instruments tool...
  • I am getting the error indicated.  You gotta be kidding me.  It takes a almost an hour to install a version of CCS.

    Has anybody found a better way?

  • I am having the exact same problem after going through the same sequence of events. Does anyone have a fix for this? It is rather painful!

  • Went through the above process with two more engineers.  We never found a way around it.  It was painful, but we are over it in about two days per engineer.

  • FYI - this issue has been fixed in CCS v5.5.0, which is currently available for download.  The issue is tracked as: SDSCM00047639 NPE during project build after upgrading the project's compiler version.

    The problem appears when user changes the compiler version on certain types of projects in CCS v5.4.0 and earlier.  Thus, please avoid changing the compiler version on your projects until you upgrade to CCS v5.5.0.

    If you already have changed the version, and are experiencing this NPE, you will need to restore your project.  I would recommend, in general, to use some type of a source-control mechanism - either a source-control utility, like CVS (which has a very good Eclipse integration), or even just backing up your projects periodically.

    Thanks, and I apologize for this very crippling bug.

    - Baltasar

  • Do i have to reinstall the whole Code Composer or is an update in the IDE enough? I made an update in the CCS5.4 and after i see the following version:

    Code Composer Studio Base Components: 5.4.0.00279

    CCSv5 Service Realse Windows: 5.5.0.00077

    But i have still that bug. I used a working project file from the repository and first compiled the whole project with success. After i changed the compiler version from C6000 7.4.4 back to 7.2.12 i got that know error!

    Errors occurred during the build.

    Errors running builder 'CDT Builder' on project 'DSP'.

    java.lang.NullPointerException

     

     

  • I believe we just saw this error in going from 5.4 to 5.5.  It befuddled us.  As our project source, including project files, were under source control, we reverted the old project file.  I believe we did not even close CCS.  The next build did not have the error.

    I know going from 5.3 to 5.4 and the 4.9 to 5.0 ARM build tool chain broke the .cproject file.

    {I note that after this we made edits to the .cproject file without closing CCS and magically, other errors (bad include paths) disappeared.  CCS seems to sense the .cproject file changed outside of CCS and reloaded! }

  • When will this issue actually be fixed?  I am running the latest version of CCS 5.5.0 and I still can't get my old project using compiler version 4.9.3 updated without getting this specific error.  I reverted the code, tried again and it still doesn't work.

  • My recollection of going from compiler 4.95 to 5.0 was horrid.  If you updated the compiler first, then CCS, things worked.  If you made the mistake of updating CCS first, then you had problems.  I recall having to uninstall CCS 5.x, uninstall the compiler (uninstall hangs so you have to either delete or rename the C:/ti directories), then revert your code base, mainly the .project, .cproject files.  Then update the compiler, then update CCS.  It took a couple days to iron out.

    BTW, other threads on installing CCS indicate if you are on Windows:

    1. Get the standalone installer
    2. Install from your C drive, not a network drive
    3. Disable virus checking
    4. Get admin rights.

    Our average install for a new engineer is over two days with 4-5 install/uninstall cycles.  Manager is almost looking at IAR.  Next engineer will follow above rules.

    (Or dang it, was it the other way around.)

    There are other threads on this issue.

     

  • Tim,

    The project corruption issue, originally reported in this thread, has been fixed in CCS v5.5.0.  See my earlier post - http://e2e.ti.com/support/development_tools/code_composer_studio/f/81/p/226067/1014629.aspx#1014629 .

    Note that if your project has already gotten corrupted due to this bug, upgrading to CCS v5.5.0 won't fix your project.  If you can attach the .cproject file from the root of you project, i can see if i can manually salvage your existing project for you.

    Thanks,

    - Baltasar