This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

LAUNCHXL-CC1310: Does EnergyTrace support LaunchXL-CC1310?

Part Number: LAUNCHXL-CC1310
Other Parts Discussed in Thread: ENERGYTRACE, , CC1310


I am using CCS 10.4.0 with a LaunchXL-CC1310. I can't get EnergyTrace to work. I have tried two things:

1) I start a debug session, but the EnergyTrace icon is greyed out.

2) I start EnergyTrace, and it starts fine. Then I start a debug session, but the EnergyTrace part of the window closes.

Am I doing something wrong, of is this LaunchXL not supported?

Thank you

  • EnergyTrace isn ot supported on the CC13x0 LPs. However, if you have a CC13x2 LP you can connect this to the CC1310 LP to measure the current.

    the LPs should then be connected as shown below:



  • Thanks Siri. Please tell me more about the CCS connection / setup. 

    A few questions:

    1) I would like to run the 1310 through the debugger while measuring the current. Is that possible? Or does the 1310 have to be stand-alone running from flash? 

    2) I assume I would run EnergyTrace on the 13x2, is that correct?

    3) Is this documented somewhere?

  • 1) I checked with our HW group and they said it should be possible to debug the CC1310 while running ET, but you would need to run the debugger on the CC13x2 LP.

    It should be connected like this:

    2) yes

    3) No, but I know that there has been made a ticket to get this info into the SDK documentation.


  • Thanks Siri,

    Regarding 1), using this wiring diagram, when I download the code using the debugger via the 13x2, I assume the code will be running on the 1310. Is that correct?

    When the 1310 code is in the 1310 flash, and I have it connected using the two wire diagram you first sent, what are the steps to get EnergyTrace working? I have a 1312 LaunchPad on order, so I can't try it at the moment.

  • First of all, I have now tested the setup I showed in the last post, and I am not able to get that to work, so I will have someone from the HW team to comment on that.

    Not even sure that it should be possible to run the debugger when using ET (from the user guide "Make sure no debug session is active and click the EnergyTrace Button......."

    What I have tested is the first setup I described.

    The procedure there is to first download the code you want to test to the CC1310 (Like you normally do). When the CC1310 has the proper code in flash, you remove the jumpers and connect it to your CC13x2, as shown in my first picture.

    The CC13x2 should be connected to your PC via USB, and the CC1310 is powered via the CC13x2 (no USB connected to it).

    You should then follow the steps from the user guide:


  • Please use the following:

    With this setup, I was able to download the code to the CC1301 via the CC13x2. I was also able to run ET from the CC13x2, with and without the debugger running. Not sure why you want to have the debugger running when measuring the current consumption. The debugger will add to the total current, and also prevent the CC1310 from entering Standby mode etc.



  • Thank you for continuing to follow up on this Siri. I will try it out. I am waiting for a 1312 LaunchPad. I would like to keep this issue open until I can try it. Thanks!

  • I connected the 1312 LaunchPad as shown in the first diagram (only two wires to the 1310 LaunchPad).

    I ran EnergyTrace, and a dialog appeared that said a firmware upgrade was required (regrettably I didn't take a picture).

    I can't figure out which firmware it is talking about. Using xdsdfu I found that the XDS firmware on both boards (1312 and 1310) is

    That is the newest version I can find.

    Is there other firmware on the 1312 that would need to be updated to use EnergyTrace?

    Also, after dismissing that dialog, the EnergyTrace tab no longer appears when I run it. When I run it, the dialog that says "Detecting EnergyTrace Pod" appears then goes away. Nothing new appears in CCS. What should I do?

  • Please provide information regarding what SDK version you are using for you CC1310 code development and also which CCS revision you use. Remember to make sure that you use the same CCS version as the SDK is made for.

    When testing I noticed that of you use the latest setup (5 wires going from CC1312 LP to CC1310 LP), you can download code to your CC1310, you can debug the code and you can run EnergyTrace.

    However, EnergyTrace will only work if you start the debugger first and have this running when running EnergyTrace.

    If you want to run EnergyTrace without running the debugger, you first have to make sure that you have downloaded the code to the CC1310. You then should remove the 3 wires connecting RST, TMS, and TCK together. It will now be possible to start ET.

  • Thanks Siri. I am using CCS

    The 1310 SDK is

    The 1312 SDK is

    I've put the 1310 code in it's flash, so I think I'm all set there. 

    I haven't put anything in the 1312 flash, because I assume that is just a conduit to measure power on the 1310. Is that right, or do I need to put something in the 1312's flash.

    Assuming the SDK versions look ok, what do you think about EnergyTrace window not appearing when I press the ET button? 

    Is there a way for me to have CCS check the 1312 LaunchPad's firmware and update it, if necessary?

    Thank you

  • I have an update. Using the debugger, I am running the "hello" program on the 1312. I am using the two wire setup with the 1310. I am successfully using EnergyTrace. My goal is to measure the current usage on the 1310. Is this the correct way to do it?

    Is the current usage in the graph only the current usage on the 1310, or does it also include 1312 current usage? If it includes current usage from the 1312, is there a way to approximate how much that is?

    Also, is there a way to change the units on the EnergyTrace graphs? Currently, it is in nA, but I would like it to be mA.

  • Hi

    I am not sure I understand what you mean when you say you are running the debugger and measuring the current using ET and the 2-wire setup.

    With the 2-wire setup, the debugger is not connected, and hence is not running.

    With the 2-wire interface you have to either download the code directly to the CC1310 having the USB cable connected to the CC1310LP, or you can download the code via the CC1312LP, using the 5-wire interface.

    Having the 5 wires connected, you need to have the debugger running when running ET, and the current consumption will be higher due to the debugger.

    Disconnecting the debug interface, and just having the 2-wire interface, the debugger is not running, and you are measuring the CC1310 current.

    I downloaded the rfPacketTX example the the CC1310LP and changed the packet interval to 3 s.

    The first plot shows the current consumption when using the 5-wire setup and debugger running. As you can see, the debugger is preventing the CC1310 to enter standby mode in-between packets, and the average current consumption is high.

    In the second plot, the debugger is disconnected (2-wire setup) and the CC1310 are able to enter standby in-between packets. In addition to the very low current consumption between packets (ET is not able to measure it, so just displaying 0), you see the re-charge pulses, indicating Standby.

    It is not possible to change the graphs, I think

  • Thank you for your continuing help. Let me try again. The following only refers to the 2 wire setup:

    I have loaded my code into the 1310LP flash. The 1310LP is not connected to the debugger.

    I have the 1312LP connected to the PC via USB. For discussion, I will label these two cases:

    1) I do not run the debugger. The "hello" program from Resource Explorer is in 1312LP flash. When I go into CCS and press the EnergyTrace button, the Progress Information dialog appears, then disappears. When the dialog disappears, the EnergyTrace window does not appear.

    2) I load and run the "hello" program from Resource Explorer into the 1312LP using the debugger. Then I press the EnergyTrace button. The Progress Information dialog appears. When it disappears, the EnergyTrace window appears and I can use it. It seems to work fine.

    Is case 1 correct or incorrect? If it is correct, why isn't the EnergyTrace window appearing?

    Is case 2 correct? For case 2, I assume I am measuring some current from the debugger, is that correct? I want to measure only 1310LP current.

  • Sorry, but I am still confused. You state that what you want to do is to measure the current on the CC1310LP, so why are you downloading any code to your CC1312 LP?

    If the purpose is to measure current on the CC1310 using ET, please do the following:

    • Download the application you want to measure current with to the CC1310. I will recommend that you for example use the rfPacketTX example, instead of the "hello" program, as the rfPacketTX will show you different states that are well defined (standby and TX), so that you can easily see that the correct code is running. To download rfPacketTX to the CC1310, you can either:
      • Connect the CC1310 directly to your  PC using usb, and then download the code. All jumpers should then be connected on the CC1310LP
      • Connect the CC1312 directly to the PC, and use the 5-wire setup that I have showed you. The example will then be downloaded to the CC1310 via the CC1312LP. The CC1312 will not have the rfPacketTX code downloaded.
    • Once you have the code downloaded to CC1310, you can either:
      • Measure the current on CC1310 with the debugger running. This is what is showed in the first picture above. If this is what you want, you need to use the 5-wire setup (remove all the jumpers as shown in the figure).
      • Measure the stand-alone current on the CC1310. You then have to use the 2-wire setup as explained above.

    Are you not able to re-create this and generate the two plots that I have shown in my previous post?


  • All of the information in my previous message pertained to the 2-wire setup. That's the first picture you sent in this thread. I am assuming the 2-wire setup is still valid. If it is not, please let me know. I have not tried the 5-wire setup yet. I would like to get the 2-wire setup working first.

    The following only pertains to the 2-wire setup:

    I am loading my custom firmware into the 1310 flash, and that works fine.

    As I mentioned in the previous message, if I don't run the debugger on the 1312, when I press the EnergyTrace button, the Progress Information dialog appears, then disappears. The EnergyTrace window never appears.

    In the previous message I provided two cases, but I'm not sure if case 1 should work.

    Hopefully this is enough information to get us back on track.

    Thank you for continuing to help!

  • When using the 2-wire interface, you will not even be able to start the debugger as the debug interface is not connected. Trying to run the debugger should result in the following message:

    Starting ET I have no problem with, with this setup. I have tested with several version of CCS.

    Please look in the following guide to see if you are setting up EneryTrace correctly:

    The only thing you should not follow from this setup is how to connect the board, as this is for running ET on CC13x2.

    If you are still not able to get this to work, please provide info regarding SDK version, pictures of setup etc.



  • I think the 2-wire setup is resolved. I didn't realize that the jumpers needed to be disconnected. Once I did that, it seems to be working. Thank you for your help.

    This is similar, but if you want me to file a new question, let me know.

    I am using a 1310 that is not on a LaunchPad. It is on a circuit board. I am connecting through a TI XDS110 Debug Probe.

    When I click on EnergyTrace, the Progress Information dialog appears, then disappears, but the EnergyTrace window never appears.

    Can you tell me the minimum connections needed with the TI XDS110 Debug Probe to use EnergyTrace?


  • Please create a new post with this questions, and someone from the HW team will pick it up.