This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

LAUNCHXL-CC3235S: Error: No Cmd Ack detected [cmd opcode = 0x8466] CSR demo

Part Number: LAUNCHXL-CC3235S
Other Parts Discussed in Thread: UNIFLASH


I am using the Certificate Signing Request demo project straight from Resource Explorer with no modifications.

I get the error "No cmd ack detected", and I can see no documentation to support customers with issues. It seems that the MCU or NWP is expecting a response of some sort to the assembly opcode of 0x8466, but I am left with no resources to troubleshoot.

Again, the Launchpad is unmodified straight out of the box as well as the code. 

Code Source:

Can someone assist with why I am not getting acks form these commands? 

I have tried using the Launchpad in AP mode as well as station mode. In my application, the MCU will be in station mode.

Thank you.

  • NOTE:

    I saw in the datasheet, that the response to this error is to call sl_Stop() and sl_Start(). This did not work for me. I threw the retries in the while() loop as seen below. Stopping and starting the device did not work. I am at a loss due to lack of resources on this topic.

    int main(void)
    /* Call driver init functions */

    /* Start NoRTOS */

    /* Call mainThread function */

    while(1)  // This while loop was empty initially to handle errors
    sl_Start(0, 0, 0);

  • what SP is installed on your device?

    Please make sure you are using the latest (SP4.11.0.0 from SDK5.20).

  • Do you mean Service Pack? I tried looking, but I'm not sure how to see what Service pack I have.
    I have confirmed that I am using SDK 5.20.

    I have these two sub-directories inside C:/ti  :

  • I now see  sp_4.11.0.0.bin and .UCF files inside the SDK directory. I also see 3.20 files. 
    I have 4.11.0 files inside the servicepack-cc3x35 directory and
    I have 3.20 files inside the servicepack-cc3x20 directory.

    These sub-directories are located at:

    Should I delete the cc3x20 folder?

    Thank you

  • As you are using CC3235 device you should use the binary (sp_4.11.0.0_3.7.0.1_3.1.0.26.bin) from the servicepack-cc3x35 directory.

    You will need uniflash/Image Creator to install the service pack (see



  • Thank you. I had a flaw in my understanding of Uniflash. I thought uniflash was obsolete because of the image creator integration with CCS. Also, I had always used the top portion of the screen to "auto connect" the launchpad which never let me do all the things I kept reading about in the docs. Every time I used Uniflash, it was only letting me flash existing .hex and .bin files. I never understood how to get to the image creator wizard/workflow.

    I was eventually able to flash the service pack on there.  Thank you for everything.