This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.


Part Number: CC3220SF-LAUNCHXL
Other Parts Discussed in Thread: UNIFLASH, SYSCONFIG,

I am developing on the CC3220SF-LAUNCHPAD in Code Composer Studio (CCS) and am experiencing a problem. The problem is that any time I want to program the CC3220 device with new code, I get the error message: 

(Error -1170 @ 0x0)
Unable to access the DAP. Reset the device, and retry the operation. If error persists, confirm configuration, power-cycle the board, and/or try more reliable JTAG settings (e.g. lower TCLK). 

My working solution is to reset the device and retry, but this is too slow. The error happens ANY TIME I want to program the device with new code, so I end up wasting a lot of time:

  1. Click the "debug" button which attempts to program the device and start the debugger
  2. Device fails with error -1170. Cancel the debug session and reset the board (with the physical "reset" button)
  3. Click the "debug" button again, which successfully programs the device.

As you can see, I have to click debug TWICE. It's frustrating that anytime I want to debug new code, I have to reset the board. Again, this happens every time I want to program the device with new code.

The online resources have said to verify the device is in develop mode and to verify the MAC address, which I've done. That's about all I found online, I don't know what else I can do. Any help will be greatly appreciated.

Thank you!

  • Do you have only one board? this seems very strange (-1170 may happen occasionally but certainly not every time) and may indicate a problem with the board.

    Another thing to check is if you programmed the device with an MCU image (i.e. in the flash file system using uniflash or CCS) that somehow interferes with the CCS debugger. If you have an image programmed try to reprogram the flash without it.

  • Hi,

    I agree with Kobi. It looks like that pins for JTAG/SWD are re-configured at runtime for alternate function and from this reason debug from CCS does not work every time. You should check what MCU image is programmed at sFlash and what pins are used at your CCS code (configured Sysconfig).

    Few questions:

    • what is your SOP pins mode?
    • how is configured target at CCS (JTAG or SWD)?


  • Just the one board, but more are on the way soon. I'll be interested to see if the issue persists with those.

    Remind me, how do I program the device without an MCU image in CSS? I thought a CSS project would automatically program the flash with an MCU image, but not sure/

  • Hi,

    When you start debug session from CCS, code is loaded into execution flash (XIP). SPI flash (sFlash) is programmed when Sysconfig Image Creator is used.

    With SOP mode 010 is 4-wire JTAG used. Maybe you have re-configured TDI, TDO pins to alternate function. Maybe you can try to change SOP mode and target configuration to SWD (2-wire JTAG).


  • Thanks, although I'm still not sure how to do any of this.

    • Does changing SOP mode mean to change the wiring on the physical pins, or is there a way to do this in CCS?
    • Where do I change the target configuration to SWD?
    • You mentioned Sysconfig but I'm not sure what to do with it. There are two sysconfig files in my CCS project, would I look at one of those? There's image.sysconfig and project_name.sysconfig... which of these do I modify, and what do I modify?

    Note that I have also tried using Uniflash to program the device with no image, but that does not help.

  • Hi,

    SOP mode is configured at CC3220SF-LAUNCHXL using SOP jumpers (J13). SOP jumpers allow to setup debug interface (JTAG/SWD) and ROM bootloader mode. For more details see datasheet at chapter 9.8.1.

    If you want to switch debug from 4wire JTAG to SWD you need to select SOP mode 0-0-1 (2-1-0) and set target configuration to SWD at CCS.

    How works Sysconfig Image Creator is described here.


  • Thanks Jan, I followed the steps and set my configuration to SWD and SOP mode to 001. After doing so I tested the connection in the .ccxml file and there was a connection success. However there is now a new problem: I cannot build my project. Anytime I wish to do so I get the following error:

    SLImageCreator.exe: BootLoaderError, Timeout reading data

  • Hi,

    I don't see any reason for such error message when you start debug session from CCS or build your project. But this message can be shown when you try to program sFlash (SPI flash) using Image creator. Because at SOP mode 001 does not work programming via ROM bootlaoder.


  • Yes, this is happening when I try to start the debug session from CCS. It only happens when I am in SOP mode 001 and SWD mode. Strange.

  • Hi,

    Can you provide here some screenshots of CCS  (e.g. how do you start debug session, etc.), because what you see does not make any sense.


  • Hi Jan,

    Step 1: Set the target configuration to SWD mode...

    Step 2: Test the connection... successful!

    Step 3: Press the debug button...

    Step 4: Watch the console... notice the error 

    Step 5: Get this error:

    The same is true if I just attempt to "build" the project too, instead of starting a debug session.

    Hope this is helpful,


  • Hi Zack,

    Can you try to set project properties to debug (use button Manage Configuration and set active to Debug).


  • Hi,

    This was the solution. I can even go back to JTAG with SOP mode 010 and it still works. Just needed to set the active configuration to debug and I'm all set.