• TI Thinks Resolved

LMX2594: high spurious when not in integer mode

Prodigy 60 points

Replies: 7

Views: 61

Part Number: LMX2594

Hi,

on my (selfmade) testboard for the LMX2594 I measured a big difference in spurious for integer vs. non-integer mode:

Non-integer mode:

Integer mode:

Here you can finde the settings in TICS Pro (non-integer mode):

The goal is to produce an output frequency of 8.244 GHz. How can we reduce the spurious for this frequency?

Thank you very much in advance.

Best regards
Joachim

  • In the meantime I found out that switchting off VCO_Phase_Sync drastically improves the situation:

    My initial question still applies, as we want to use two phase-synced oscillators later on.

    Joachim

  • In reply to J. H. 1:

    Hello Joachim,

    Please increase your MASH_ORDER to a third order modulator this will distribute the power of the spurs across the spectrum.

    Also note that you might have to adjust other settings in the PLL such as the PFD_DLY_SEL which will be marked in yellow or red.

    Finally, you can use the PLLATINUMSIM-SW tool for PN/spur simulations.

    Thanks,

    Vibhu

  • In reply to Vibhu Vanjari:

    Hi Vibhu,

    thank you for your reply. Increasing the modulaton order does improve the spurs.

    While testing, another issue occured:

    On our board we have two PLLs, similar to TIDA-01410. When both PLLs are powered and running sometimes the waveform looks, as expeced, like in the first picture. When presing FCAL_EN in  TICS Pro sometimes the waveform stays like in the first pictures and sometimes the output looks like shown in the second picture. The output signal looks the same for both PLLs, so both are affected by the problem. Do you have any idea what is going on there? Pressing FCAL_EN a couple of times, usually helps to get the waveform back to normal. The PLLs are programmed simultaneously.

    When both PLLs are powered and only one PLL is programmed the problem does not occur.

    Thanks

    Joachim

  • In reply to J. H. 1:

    Hi Joachim,

    Are both PLLs running at the same frequency and when you run FCAL_EN, are you calibrating them at the same time?

    Looks to me that each PLL is having interference with each other. 

    My suggestion is to at least power down one of the PLL's output while programming the other PLL in order to reduce interference. 

  • In reply to Noel Fung:

    Hi Noel,

    both PLLs have exactly the same settings and are calibrated at the same time.

    I found out that when I reduce the power of the reference oscillator, the issue is much less likely to occur.

    With an ref. osc. power of 8 dBm at the PLL input the issue occurs approx. every second time I calibrate. When I reduce the power to 0 dBm it is very hard to replicate the issue.

    When only one PLL is running and calibrated the issue does not occur.

    Thanks
    Joachim

  • In reply to J. H. 1:

    Our board is very similar to TIDA-01410. Do you know if such an issue exists with TIDA-01410?

  • In reply to J. H. 1:

    Hello Joachim,

    Have  you tried Noel's suggestion to powerdown one of the PLLs while calibrating the other to reduce interference? Your results with the  reference oscillator, suggest the same. Looks like when the power is higher the interference is also more prominent.

    I am not aware of a similar problem on the TIDA board.

    Thanks,

    Vibhu