This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TM4C123G Development board unable to initialize and program

I just got my TM4C123G development board last week.  I am very new at programming embedded devices and have no experience with this platform.  

My problem is that I cannot program the board and I cannot communicate with it using the various debug tools.  

At first I was able to program the board using the example programs given by TI.  The last program I programmed was the example program boot_demo1 provided by TI.  When I try to program the anything using LM Flash Programmer or CCS using the settings given by the User Guide it says, "**ERROR**: Unable to find a target!" 

I've tried going to flash utilities and using the debug port unlock.  Once I got all the way through it where it says to repower the device, but now its saying "Failed to unlock connected device!".  I am holding down the reset button and following the on screen instructions.  I've tried doing a hardware reset using the LM flash programmer but the error says, "Cannot find target device!".  I've used two computers for this one with Windows 8 and the other with Windows 7.

Lastly the power light is not lit by default.  I have to press the button labeled "SELECT/WAKE" for the power light to show up.  Why is this?  Is this by default or was it part of the boot_demo1 program?  Also when I try to do the debug procedures listed above the "In-Circuit debug interface" light flashes once.   

I have a project to do with this board and I need to get this fixed soon.  Thanks in advance.  

  • Hi Brandon,

         Try, using LM Flash Programmer "Erase Entire Flash" at Flash Utilities tab. 


  • I tried doing the "Erase Entire Flash" option at the flash utilities tab.  I get the error "Unable to initialize target - 0!".  I've triple checked my drivers to make sure they are installed correctly by using the driver installation guide.  I'm pretty sure that the drivers are installed correctly because in the device manager I have entries of "Stellaris Virtual Serial Port (COM3)", "Stellaris ICDI DFU Device", and Stellaris ICDI JTAG/SWD Interface".  

    When doing the Debug Port Unlock I get the error "Unable to initialize target - 1!".  The numbers at the end are different. 

    From the error messages I've received, it seems as though the board is refusing to communicate no matter what I do.  I'm thinking that there is a hardware fault in it.  

  • Would anyone know whether the pink shiny bubble wrap that this board comes in is anti-static proof?  Apparently I was transporting the board just using this and not the gray shiny static shield bag.  Would this make a difference?

  • One thing you might double check is the VDDC voltage on the board.  There should be a pretty big via for it under the jtag header (line of vias for jtag signals).  My board is around 1.2V.  I know I've had problems with VDDC in custom boards because they require a pretty specific capacitance.  Also the vdd jumper should be in, but you probably have that if you come this far.

  • Thanks for the message Robbie.  I'm actually working with Brandon to get the boards working.  We're working on a project together and neither of us has much experience with Microprocessors.  Anyways, I fiddled with the board a little bit and the Power light likes to go off relatively frequently.  Especially when the rubber piece that connects the circuit is removed(I forget what it's called and will possibly look it up later).  When the Select/Wake button is pressed the power button always goes on and when the rubber piece is removed it also goes on(the rubber piece is connected to JP3 I believe and has HIB and DISC above it.  If I remove the rubber piece while holding select/wake the power button will stay on, however if I press the reset button afterwards it turns off.  We will be checking the voltage later, but have not been able to do so yet.  We also have another board that we are using and it is working.  Let me know if you have any more ideas/have encountered this before, I'm beginning to think the circuitry may have messed up :/

  • My guesses were actually incorrect.  I fixed it by removing the battery and turning it off and then plugging it in again.  Bam!  Worked with CCS!