This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

MSP432P401R: Cannot connect to target after loading wrong code

Other Parts Discussed in Thread: SEGGER, MSP432P401R


After loading a piece of code on the target (MSP432P401R), I can't connect to it anymore. This board was working perfectly with another set of code. Both JTAG emulators I own (XDS110 or Segger J-Link) give me the same target connection error. The code I loaded was an almost empty piece of code with just the minimum board config (like the clock) and a few pins defined for testing the UART module.

I tried the "Factory Reset Without Password" steps from doc SLAU575K (Code Composer Studio IDE for SimpleLink MSP432 Microcontrollers), but this doesn't work either, it fails at the "Connect Target" step. After that I can't execute any GEL script since I'm not connected to the target. I tried with both JTAG or SWD options for the target configuration.

Before I start replacing the MSP432 chip on this board, can anyone think of any other steps I can perform to unlock this chip?



**Attention** This is a public forum