This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

MSP430FR1433 factory reset?

Other Parts Discussed in Thread: MSP430FR4133, ENERGIA


I just started to use my MSP430FR4133 LaunchPad, I have no experience is controllers.

I am wondering how I can factory reset my LaunchPad?

Indeed, I tried to get started with Energia Software.

When I tried to upload a soft to the Launchpad, Energia lauchned an update of the LaunchPad firmware.

The Update did not ended well. (I saw right after that FR4133 was not handled by Energia, and I guess this is the reason of the crash.)

Now, the LaunchPad is not recognized as a COM port by the PC;

When I plug it to the PC, the LED102 is green, and the LaunchPad is recognized as an USB input port, but not as port COM. The LCD display is off.

So I cannot acces to it with development softs. Can I come back to initial factorey settings?

Thank you for your time and your help


  • Hello Vianney,

    It is possible the on board Emulator could of been written over instead of the target MSP430FR4133. Have you attempted to connect the Launchpad to Code Composer Studio (CCS)? If you were to try to load a code example for the FR4133 with CCS, it should detect the LP and update the emulator. If this is not the problem, CCS should still help you get the device into a known state (i.e. with a code example loaded) so you can build off of there.

    Hope this helps!

  • Hello JH, 

    Thank you so much for your answer. (and sorry for the late feedback)

    I tried to connect the LP with CSS, it updated the firmware and my LP is back in its factory configuration ;-)

    Thank you again, 



**Attention** This is a public forum