This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • TI Thinks Resolved

CCS/MSP-EXP432E401Y: demo program power measure stops at sl_Start(0,0,0)

Prodigy 60 points

Replies: 6

Views: 191

Part Number: MSP-EXP432E401Y

Tool/software: Code Composer Studio

Having read similar problems with the MSP-EXP432E401Y board and SimpleLink modules, I cannot find a way to get the demo program to initialize the wifi module and run. 

It appears to hang in an infinite loop when sl_Start(0,0,0) is called in displayBanner() method.

The CC3120MOD provisions correctly using the mobile app and is able to be flashed using Uniflash and the CC31XXEMUBOOST module.

I have tried using both a BOOSTXL-CC3120MOD and a BOOSTXL-CC3135 with the MSP-EXP432E401Y and both have same problem.

We are using CCS  Version: 8.0.0.00016 with Simplelink MSP432E4 SDK 2.40.0.11 and SimplLink SDK WiFi Plugin 2.40.0.22

Hope there is a solution?

  • Hi,

    Which demo program are you running?

    Also, how did you provision the CC3120 through the mobile app without having it working with a MSP432? Were you using another platform before?

    The MSP432E4 + CC3120 combination should have no issues. Building and running the network_terminal example, I am able to get the CC3120 past sl_Start() on my setup.

    If you could provide pictures of your MSP432 + CC3120 jumper configuration, that would be useful for review. Also, please ensure that you have mounted the CC3120 onto the second set of Launchpad headers, the one closest to the ethernet socket.

    Regards,

    Michael

  • In reply to Michael Reymond:

    Michael

    Thanks for quick response.

    Your demo program that we are trying to get working is power measure ( ~\ti\simplelink_sdk_wifi_plugin_2_40_00_22\examples\nortos\MSP_EXP432E401Y\demos\power_measurement ) as mentioned in title.

    The provisioning was performed using the CC31XXEMUBOOST to provide the power and comms link via a wireless access point as per SWRU472A–February 2017–Revised April 2019. Using wireshark I can see the device on the network when using this module. When using the power measure demo and the MSP432E401Y the device does not connect to the network.

    I've attached the board pictures showing jumper settings. I also tried this with the VCC-RST jumper removed and still had no joy. 

  • In reply to Bob Cudmore:

    Hi,

    JP1 on the MSP432E4 launchpad should be in the 5V-XDS position, assuming you are powering the board through the main USB connector next to the XDS110 debugger. Could you also show me the rest of the jumpers on the MSP432E4 launchpad, especially the ones closest to the debugger?

    The jumpers on the CC3120mod boosterpack are correct. The LED and RST jumper shouldn't affect the operation of the power management demo.

    Do the LEDs on the CC3120mod light up once you power up the MSP432E4 board? If they don't there might be some power issue with your board.

    Let me know if changing the JP1 jumper setting doesn't work

    Regards,
    Michael

  • In reply to Michael Reymond:

    Michael,

    I've changed the power jumper J1 to use XDS  though it was powered from the ext usb input next to the LAN port previously and include a photo of the other jumpers on the MSP432E401Y.

    There is no difference to the power up and the power measure application drops into the faultISR(void) line #270 of startup_msp432e4_ccs.c

    The application appears to load onto the board correctly and the leds all come on as in attached picture. The green led by TP1 comes on when the debug is set to run.

    Bob

  • In reply to Bob Cudmore:

    Hi Bob,

    Your jumpers look correct. As far as I can tell, there shouldn't be anything wrong with your hardware setup anymore. 

    There is probably some issue with the code you're running on the MSP432E4. I have compiled and built the .out binary for the network terminal example here:

    /cfs-file/__key/communityserver-discussions-components-files/166/network_5F00_terminal_5F00_MSP_5F00_EXP432E401Y_5F00_tirtos_5F00_ccs.out

    I've also built the power_measurement binary:

    /cfs-file/__key/communityserver-discussions-components-files/166/power_5F00_measurement_5F00_MSP_5F00_EXP432E401Y_5F00_tirtos_5F00_ccs.out

    Those work on my setup. Please give it a try on your hardware and see if it works.

    To load a .out manually, you can follow the instructions I have here: https://e2e.ti.com/support/wireless-connectivity/wifi/f/968/p/677460/2494156#2494156

    The key difference is you actually want to load program, and not just load symbols.

    Regards,

    Michael

  • Bob Cudmore
    It appears to hang in an infinite loop when sl_Start(0,0,0) is called in displayBanner() method.

    Were you trying to single step the code in the CCS debugger when the problem occurred?

    In the past found that how the debugger was configured to handle interrupts could cause issues with sl_Start, albeit with a CC3200 rather than MSP432 + CC3120MOD. See CCS: Problems when debugging CC3200 Launchpad in SWD mode

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.