This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

Installing CCS5.2 under Ubuntu

Other Parts Discussed in Thread: MSP430F2274


I am trying to install CCS 5.2 (beta)  in Ubuntu for MSP430 microcontrollers following the installation instruction hat comes with the download. However I noticed during installation the "Select Emulators" window does not have the FET Emulator to select as the emulator I wanted.

The installation goes through and I can compile the code; however I cannot flash it to msp430 as it did not find the USB FET driver.

Alternatively I don't see the file under install_script/ folder as mentioned in the README_FIRST instruction file.

Am I missing anything in the installation process? Do I have to install the USB FET driver separately? If so where shall I get a driver for Linux which I can try out?

Thanks -Abhijit Das

  • Hi Abhijit,

    did you install and run as root?  With permissions for all folders?   We have seen some cases where permissions settings have blocked CCS from writing somewhere in the Linux case and unfortunately without generating much of an error in some instances.

    Do you have all required dependencies listed?   If you are on 64 bit Ubuntu, then 32 bit support is necessary.

    What version of Ubuntu is this?  I have not needed to install FET drivers separately and have programmed an MSP sucessfuly with 5.2 in Ubuntu 11.10 32 bit.

    Please keep us informed.

    BEst Regards,

  • Hello Lisa,

    Yes I installed CCS5.2 as root following the README_FIRST.txt file that comes with the download.

    sudo ./ccs_setup_5.2.0.00044.bin

    I am using Ubuntu 11.10, 32 bit machine.  I also tried it on Ubuntu 10.04 LTS with no luck.

    You mentioned that it is installed properly in your place. So I think I am missing something in my installation.  Is there a way to generate some debug information to help be debug what is going wrong?

    Your help is highly appreciated.

    regards --Abhijit Das

  • Hello Lisa,

    Just one more thing. What are the dependencies for install CCS 5.2 under Ubuntu?  Can you please list out the packages I need  (if any) before installing CCS 5.2 to enable proper USB FET driver installation?

    Thanks in advance -- Abhijit Das

  • Hi Abhijit,

    have you been able to install?  ( I ask as you verified the answer)

    Have you seen this wiki with some details on dependancies and various Linux versions?

    Best Regards,

  • Hello Lisa,

    No. Could not resolve it yet. I clicked on the "Verify" button by mistake.

    On the dependency thing,  I saw the list of libraries (.so files) in the wiki page. I was manually checking if those libraries are present in /usr/lib or not. There are minor variations and moreover it is difficult to figure out which library is included in which package... If the CCS developers (linux platform ) tell us the packages CCS depends on then it will be much easier exercise...

    How do I know which package to load if I miss out something. Another thing I would love is to have some debug trace which can promptly tell why it is missing out the USB FET driver.

    Regards -Abhijit Das

  • Abhijit Das,

    There is a couple of things we can check:

    (1) When the USB FET is plugged into the computer, from a terminal windows type lsusb -t . Do you see a device that looks like this:

    /:  Bus 05.Port 1: Dev 1, class="root_hub", Driver=uhci_hcd/2p, 12M
        |__ Port 1: Dev 4, If 0, class="comm"., Driver=cdc_acm, 12M
        |__ Port 1: Dev 4, If 1, class="data", Driver=cdc_acm, 12M

    If you type sudo lsusb -v., you should see output like this for one of the devices:

      idVendor           0x2047
      idProduct          0x0010
      bcdDevice            1.04
      iManufacturer           1 Texas Instruments
      iProduct                2 Texas Instruments MSP430-JTAG

    that would tell us the device is being recognized by the kernel.

    If the device is recognized, then we investigate next why CCS cannot find it.

  • Hello Andy,

    Here is what I got following your instruction:

    $ lsusb -t
    /: Bus 05.Port 1: Dev 1, class="root_hub", Driver=uhci_hcd/2p, 12M
    /: Bus 04.Port 1: Dev 1, class="root_hub", Driver=uhci_hcd/2p, 12M
    |__ Port 2: Dev 2, If 0, class="comm"., Driver=cdc_acm, 12M
    |__ Port 2: Dev 2, If 1, class="HID", Driver=usbhid, 12M
    /: Bus 03.Port 1: Dev 1, class="root_hub", Driver=uhci_hcd/2p, 12M
    |__ Port 2: Dev 2, If 0, class="HID", Driver=usbhid, 1.5M
    |__ Port 2: Dev 2, If 1, class="HID", Driver=usbhid, 1.5M
    /: Bus 02.Port 1: Dev 1, class="root_hub", Driver=uhci_hcd/2p, 12M
    /: Bus 01.Port 1: Dev 1, class="root_hub", Driver=ehci_hcd/8p, 480M
    $sudo lsusb -v
    Bus 004 Device 002: ID 0451:f432 Texas Instruments, Inc. eZ430 Development Tool
    Device Descriptor:
    bLength 18
    bDescriptorType 1
    bcdUSB 1.10
    bDeviceClass 0 (Defined at Interface level)
    bDeviceSubClass 0
    bDeviceProtocol 0
    bMaxPacketSize0 8
    idVendor 0x0451 Texas Instruments, Inc.
    idProduct 0xf432 eZ430 Development Tool
    bcdDevice 1.00
    iManufacturer 1 Texas Instruments
    iProduct 2 Texas Instruments MSP-FET430UIF
    iSerial 3 89FF4225A511081D
    bNumConfigurations 1
    Configuration Descriptor:
    bLength 9
    bDescriptorType 2
    wTotalLength 85
    bNumInterfaces 2
  • I checked with the MSP430 team and found that the ezFET type USB interfaces are not supported on Linux. The only supported MSP430 FET on Linux is the FET430UIF.

    Unfortunately, the interface you are trying to use will not work under Linux.

  • HI,

    Try this alternate solution (Debug under CCS and Dump under mspdebug)

    LAUNCHPAD and MSP eZ430 RF :

    Step 1: Install Linux version of CCS (Code Composer Studio 5.2 version is the latest one).

    Note : Softwares are available at TI site. You may have to create an account in the site to download the software.

    Step 2: Type in a “terminal” window command “uname -r” to know your linux kernel version. (it is of the form “3.2.0-29-generic-pae”). Copy the file “/lib/firmware/<kernel_version>/ti_3410.fw” to “/lib/firmware/ti_3410.bin”.

    Note : Please note the extension .bin and .fw.

    Command : sudo cp /lib/firmware/<kernel_version>/ti_3410.fw /lib/firmware/ti_3410.bin

    Step 3: Install package called “mspdebug” using the below command,

    Command : sudo apt-get install mspdebug

    Note : The above package is dependant on other msp430 related tools which also need to be installed. (msp430mcu, msp430-libc, gcc-msp430, binutils-msp430, msp430-gdb).

    Step 4: Create a file “/etc/udev/rules.d/46-TI_launchpad.rules” using below command,

    Command : sudo gedit /etc/udev/rules.d/46-TI_launchpad.rules

    Contents of this file to be : ATTRS{idVendor}==&quot;0451&quot;, ATTRS{idProduct}==&quot;f432&quot;, MODE=&quot;0660&quot;, GROUP=&quot;plugdev&quot;

    Save the file and exit.

    Then type command in a terminal window as : sudo restart udev

    Note : Please restart your computer, if needed.

    Step 5: Open CCS and write a sample program on MSP430. Build the project and Debug, which will result in a file called with extension “.out” that need to be dumped.

    Note : Please note we can NOT dump the coding into MSP430 that use USB interfaces because the CCS does not support Linux USB drivers for MSP430. Hence we are using alternate tool mspdebug to dump the coding. Here, we rae trying to use rf2500 driver for the LANCHPAD too.

    Step 6: Open a terminal window and change directory to the location where the output file (.out) file exists and Type “mspdebug rf2500”. Note : This need to be done after connecting the Kit (MSP LAUNCHPAD / MSP eZ430 kit) to Linux host. You should get below messages if everything went fine,

    MSPDebug version 0.18 - debugging tool for MSP430 MCUs

    Copyright (C) 2009-2011 Daniel Beer <>

    This is free software; see the source for copying conditions. There is NO


    Trying to open interface 1 on 004

    Initializing FET...

    FET protocol version is 30000002

    Configured for Spy-Bi-Wire

    Set Vcc: 3000 mV

    Device ID: 0xf227

    Device: MSP430F2274

    Code memory starts at 0x8000

    Number of breakpoints: 2

    fet: FET returned NAK

    fet: warning: message C_IDENT3 failed

    fet: FET returned NAK

    fet: warning: message 0x30 failed

    Available commands:

    = delbreak gdb load opt reset simio

    alias dis help locka prog run step

    break erase hexout md read set sym

    cgraph exit isearch mw regs setbreak

    Available options:

    color gdb_loop iradix

    fet_block_size gdbc_xfer_size quiet

    Type "help <topic>" for more information.

    Press Ctrl+D to quit.


    You can flash the programs, now, in this new command prompt and sample commands for this command prompt are as given below,

    prog abc.out : This will write abc.out into flash memory.

    run : This will run the program fed into the flash memory.

    reset : Please type this command before dumping another code.

    Note : You may type “help” to know more options available.

    We tried the above methods on both MSP eZ430 and Launchpad kits and worked.

  • Thanks a lot!  I was having the same problem as OP and this solution worked for me.  Its a shame I can't use the GUI but I can at least verify my code is working using this command line tool.  Please consider this issue in your next CCS patch TI devs!

  • Thank you so much for this excellent post!  I have followed the directions successfully but when I run mspdebug <my_out_file>.out, I get an error "unknown driver".  So I typed mspdebug --help and got this back:

    Available drivers are:
            eZ430-RF2500 devices. Only USB connection is supported.
            Olimex MSP-JTAG-TINY.
            Olimex MSP-JTAG-ISO.
            Simulation mode.
            TI FET430UIF and compatible devices (e.g. eZ430).
            TI FET430UIF bootloader.
            TI generic flash-based bootloader via RS-232
            GDB client mode
            TI MSP430 library

    I created /etc/udev/rules.d/46-TI_launchpad.rules as you described, and changed the &quot; in the post to actual quotes.  Any suggestions?  I feel like I am very close!

  • O the Embarrassment.  Please ignore the above post.

    I apologize.  I typed mspdebug rf2500 as you clearly instructed and got the interface.  This allowed me to load and run my code successfully on the rf2500.

    This worked for me in CCS 5.2 on Ubuntu 12.04 LTS.

    Many thanks, John

  • Hello,

    These links could help someone in this regard.



    Thanks & Regards,